5

I have installed Compiz on Xubuntu 11.10 with

sudo apt-get install compiz compizconfig-settings-manager
compiz --replace ccp &

In the process the XFCE window decoration theme is overridden by that of Compiz (Gtk) which uses the Adwaita theme instead of the Greybird theme. Since Gtk is doing window decoration, I cannot change it back using the XFCE settings.

I just need compiz for scale and window switch and I would like to return window decoration to XFCE (Xfwm4) or to be able to change the Gtk window decoration theme.

How can I do that?


I have found part of the (workaround) answer already:

  1. download Greybird Gtk theme
  2. install theme (here is where I failed I think)
  3. use dconf-editor to change the Gtk theme in org.gnome.desktop.interface

The problem really at stage 2 is where do I place the theme? I tried in ~/.themes/ and then changed the value of gtk-theme in the editor to Greybird. But I saw no change.

  • So you have Compiz installed but you only use it for stuff xfwm4 and xfce panel are more than capable of on their own? -_- – It's Willem Jun 14 '15 at 19:20
3

In XFCE/ Compiz , you have to use the Gnome Tweak Tool to change the window decoration, the XFCE settings only affect the GTK and icon themes.

If not installed, you can get Gnome Tweak Tool like this:

sudo apt-get install gnome-tweak-tool
  • That worked :D thx – It's Willem Jun 14 '15 at 19:24
6

installing gnome-tweak-tool would pull almost the entire Gnome as dependencies. I had the same problem today and I didn't want to install such a lot of unneeded stuff only to change one little setting and spent some time researching how these things are related and it seems it is indeed possible with gconf-editor (or gconftool-2) alone.

The key in gconf-editor is /apps/metacity/general/theme.

Type the name of an existing metacity theme into the text field (such as greybird and note that greybird is starting with a LOWERcase letter while most other themes are not!), hit enter and it should immediately change.

You can also change the arrangement of window buttons in /apps/metacity/general/button_layout (for example to move the window buttons to the right side where they traditionally belong use this: menu:minimize,maximize,close). Most other options in this section describe window behavior rather than style and don't have any effect on compiz, they would only be used by metacity.

  • for compiz 0.9.x use instead gsettings set org.gnome.metacity theme Greybird (uppercase G worked for me, lowercase did not). – drammock Jun 23 '16 at 3:32
  • Also for compiz 0.9.x, you can find installed themes by running: ls -d /usr/share/themes/metacity* – Denilson Sá Maia Sep 18 '16 at 16:02
2

I'm using xubuntu 17.10 and I'm experimenting with compiz. I use the Greybird theme but out of the box compiz window decorations do not follow the xfce theme. I had unwanted opacity in the title bar, ugly and non-themed window buttons, and a title bar which was too big.

After compiz is active, try this: (thanks to arch linux documentation https://wiki.archlinux.org/index.php/Compiz/Configuration#Workspaces_and_Viewports)

gsettings set org.gnome.desktop.wm.preferences theme Greybird

This does on the fly changes.

For me, this changed the theme but I missed maximise and minimise buttons. They can be restored by

gsettings set org.gnome.desktop.wm.preferences button-layout appmenu:minimize,maximize,close

Or, you can use gnome-tweak-tool, click Windows and turn on Titlebar Buttons Maximise and Minimise

  • Working in en Xubuntu 18.04 but I did it manually with dconf-editor – Indacochea Wachín May 23 '18 at 3:48
0

Greybird is default theme for xubuntu and can be found in murrine-themes package in the repository. You can change install it with apt and change with xfce themes setting. Then try changing with dconf-editor. Also try gconf-editor and change window theme in shell section /desktop/gnome/shell/windows to Greybird if your dconf part doesnot work

  • Thanks, I know Greybird is the default: it is the one I want to revert to and it was on before installing Compiz. Since I use Compiz, the window-decorator is Gtk and it uses the Adwaita theme. There is no gconf-editor in Xubuntu but dconf-editor only. – Benjamin Jan 25 '12 at 12:03
  • 2
    In XFCE/ Compiz , you have to use Gnome Tweak Tool to change the window decoration, the XFCE settiings only affect the GTK and icon themes. – Uri Herrera Jan 25 '12 at 13:36
  • @UriHerrera: yes it worked :) Why don't you make it an answer and get the praise? – Benjamin Jan 25 '12 at 13:46
0

Install gconf-editor using apt and that works perfectly.

Install it using this command;

sudo apt-get install gconf-editor

Then either find "Configuration Editor" in your menu or type gconf-editor in a terminal.

0

-Update in 16.04 -In Dconf-Editor org>gnome>metacity Change theme to desired theme. In my case it was "Arc-Dark". Remember that theme names are CASE SENSITIVE. Thank you! -SirSean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.