4

I just bought a Google Pixel 2 (Android 8.0.0) and tried to connect it to my PC (Ubuntu 16.04).

I tried in developer mode and changed to USB connection setting as MTP (Media Transfer Protocol), however, when the two devices connected to each other, it only showed that Google Pixel 2 is charging but never got recognised by Ubuntu.

Any suggestions on how can I connect Pixel to my PC and transfer files between the two devices. BTW, I connect Pixel and my PC using USB c cable that comes with the phone and I tried using USB 2.0 adaptor and a third party USB 2.0 cable, it does not even show its charging.

2

I am posting this as an answer because Ask Ubuntu won't let me post it as a comment.

I have been able to connect my Pixel 2 to Ubuntu 16.04 by installing jmtpfs, as suggested in https://askubuntu.com/a/854936/297597. Once I enable MTP in the developer settings, plugging in the phone opens up a new Nautilus window with the phone contents. I used a USB 1.0 port. The frustrating part was that the connection was very unstable and kept resetting, but I think it could be due to my old USB port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.