0

In Ubuntu 17.10, I try to change the default screenshot directory used to save the image when I press PrtSc. Settings were applied in dconf-editor. I see the changes made in the custom value box. But there is no effect. Nothing happens. The screenshot still saves to the Pictures folder. Used the following line in terminal without sudo and there is no error but no change in save location.

gsettings set org.gnome.gnome-screenshot auto-save-directory "file:///home/$USER/Pictures/Captured/"

Running with sudo results in this error:

(process:8589): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=ac62be018ab5403f95ededd7e8c7f101 --binary-syntax --close-stderr”: Child process exited with code 1

The directory exists and I also tried it with my actual username instead of $USER. I have tried omitting file:// and following these answers without luck. It has worked for me in the past.

marked as duplicate by Videonauth, pomsky, pa4080, Eliah Kagan, karel Dec 2 '17 at 13:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @dessert Tried that link before posting. No joy. Also tried without file:// No joy. :( – Eloy Falco Dec 2 '17 at 11:12
  • whoops. Will do! – Eloy Falco Dec 2 '17 at 11:18
  • This directory exists. I manually move screenshots to it. I have tried using my username instead of $USER without resolve. – Eloy Falco Dec 2 '17 at 11:24
  • 1
    Obviously 17.10 doesn't use gnome-screenshot or uses it, but with different setttings than set with gsettings (which would be a really poor choice). Well then just reassign the PrtSc key to run gnome-screenshot in the settings and you're done, or am I missing anything? – dessert Dec 2 '17 at 12:59
  • 1
    This is explained here, a question to which I gave you the link earlier btw… – dessert Dec 2 '17 at 13:08