This happens every couple of weeks, that I attempt to start Nautilus, and am not able to get it running. The only way I have found to get it running again is to reboot the computer.

For a while there, I reported this bug sometimes when it happened, but stopped reporting it because it doesn't help resolve the issue.

It is difficult to see any opportunity in the near future to reinstall the operating system.

In the meantime, does anybody have any suggestions for getting Nautilus running again in these instances without rebooting the system?

  • PS This is what happens when I try to start Nautilus in a terminal. None of this means anything to me. "too long by 223 characters" OK pastebin.com/rv10R2NP – el_gallo_azul Dec 2 '17 at 1:06
  • You can run/restart it anytime by running nautilus in terminal and those "errors" are typical and can be ignored. The point is: Does it open a Window? If so it's working; if not, there's something wrong and the first comment on your bug report says it all: It seems there is something wrong with your system or hard-drive. So, have you checked your drives already? And have you been installing the updates? – user692175 Dec 2 '17 at 1:17
  • 3
    The journal launchpadlibrarian.net/330218463/JournalErrors.txt actually mentions several errors with files and a Plex library. So, most likely NOT a bug and not Nautilus fault and just a drive that needs error correction. Please check that first instead of wasting the devs time by posting the same probably-not-a-bug 5 times! – user692175 Dec 2 '17 at 1:21
  • I use my drives every day. I haven't "checked" them, and don't really know how. Yes, the operating system is completely up-to-date. OK I would prefer not to waste anybody's time. If there is a drive that needs error correction, how do I check it, and what is the most probably remedy? The OS and applications are on an SSD, and I use an internal magnetic HDD for anything requiring many write cycles. – el_gallo_azul Dec 2 '17 at 7:25
  • PS My pastebin post above shows what happens when I try to run nautilus, and that is ALL that happens. Nothing else (such as a Nautilus window appearing) happens. – el_gallo_azul Dec 2 '17 at 7:27

I've worked it out.

I couldn't get nautilus to start yesterday afternoon. I slept on it, and left the computer running overnight (working on some BOINC tasks), and just came back to it now.

I tried to start nautilus, and as expected, the Unity Launcher icon flashed but the application didn't start.

This time, I started gnome-system-monitor to see if nautilus appeared in the list of current processes. It did. Hmm.

I right-clicked the nautilus process, selected "End", and then clicked "End Process". Then I clicked on the Unity Launcher nautilus icon, and the application started normally.

I hope this process is 100% repeatable, because it will save me a LOT of time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.