16

Software center does not differentiate between snap and normal applications.

Is there anyway to change this behavior or disable the snaps in the software center altogether as I have not need for them ?

The main issue is they don't work with your theme and look horrible.

3
  • Have you ever checked this forum post? ubuntuforums.org/showthread.php?t=2328152 I hope removing snapd would help. – Hamed Dec 1 '17 at 11:52
  • 2
    I had not seen that, although i don't have an issue with snapd running as i can download and install snaps when i want them. it would be nicer to be able to remove just from software centre so I get debs over snaps. – Oly Dec 1 '17 at 12:49
  • Try removing this package & see if that helps.. gnome-software-plugin-snap – doug Dec 8 '17 at 0:35
21

Pretty simple, just remove this package, stop & restart gnome-software. (easiest thing to do is just reboot..

sudo apt purge gnome-software-plugin-snap

Then reboot & you'll not see snaps in gnome or ubuntu software app

4
  • 1
    then reboot ???!, This is not windows – Sérgio Apr 22 '19 at 14:16
  • I assume he meant restart the program, not the OS. Hey, this command doesn't work in Focal Fossa, any ideas? – Rabbit May 23 '20 at 19:28
  • Well by default 20.04 uses snap-store so no plugin needed. You could remove snap-store, i.e sudo snap remove snap-store then install gnome-software package.. – doug May 24 '20 at 6:30
  • What this command is exactly doing? – reducing activity Jun 12 at 8:05
10

I also dislike snaps. I don't use them, and it's annoying how it's always phoning home for updates. Unfortunately in Lubuntu 16.04, lubuntu-desktop has a dependency on snapd, so it's awkward to just remove it.

You can at least permanently kill it by doing

sudo systemctl stop snapd
sudo systemctl disable snapd
5
1

Try in the command line:

sudo apt purge snapd ubuntu-core-launcher squashfs-tools
1

In addition to disable - described above - here is a very good article with instruction for cleaning up your system more elaboretly: https://www.kevin-custer.com/blog/disabling-snaps-in-ubuntu-20-04/

It basically says:

  1. do snap list
  2. snap remove all items (by dependency order)
  3. apt purge snapd
  4. clear various files at /home/*/snap, /usr/lib/snap and alike

In case of the server the only snap was lxd - something Canonical is pushing as an alternative to docker.

IMHO this a bit of a conflict of interests between Canonical and the users. Users should be able to opt-in whatever they need and not be forced to uninstall stuff the hard way..

0

use Synaptic package manager to delete Snapd. You can remove Snapd, the snapd login service, and libsnapd-glib1. As I recall do NOT enter it in the system log, but it probably is in the Synaptic log.....) it was a clean remove and freed up some disk space, got rid of the loops on the HD. If you have Synaptic, remove everything snapd. If you do not have synaptic then sudo apt-get update and sudo apt install Synaptic should get you the package manager. I use either Aptitude, apt or Synaptic on my system to make sure dependencies are handled. Aptitude is the most through but can cause problems because it is aggressive, apt is better from the terminal and Synaptic works well since it has a nice GUI front end. Hope all of this helps. or Removed the following packages: snap-confine snapd ubuntu-core-launcher Upgraded the following packages: snap-confine (2.22.2) to 2.22.3 snapd (2.22.2) to 2.22.3 ubuntu-core-launcher (2.22.2) to 2.22.3 Removed the following packages: libsnapd-glib1 snapd snapd-login-service

Upgraded the following packages: tcpdump (4.7.4-1ubuntu1) to 4.9.0-1ubuntu1~ubuntu16.04.1

why did snapd reinstall an updated package if I ripped snapd out by the roots, yes? open a terminal and run sudo Nautilus and when the file manager opens, I searc for snapd. Find several folders and a bunch of files, highlighted them all and deleted then .However after removing all of this gradu, reboot the machine...... shut down and boot in verbose mode to try to read the rapid text that flashes by and spot problems. Clean reboot. So far operating normally

0

The issue with just uninstalling snap/snapd is that Ubuntu is (extremely annoyingly) migrating a bunch of their packages into snaps, which will then reinstall snapd.

To block any packages that depend on snaps from being installed permanently:

echo "Package: snapd" | sudo tee /etc/apt/preferences.d/block-snapd
echo "Pin: release *" | sudo tee -a /etc/apt/preferences.d/block-snapd
echo "Pin-Priority: -1" | sudo tee -a /etc/apt/preferences.d/block-snapd

This effectively prevents snapd, and any packages that depend on snapd from getting installed:

durr@atombox:/etc/apt/preferences.d$ sudo apt install chromium-browser
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 chromium-browser : PreDepends: snapd but it is not installable
E: Unable to correct problems, you have held broken packages.

The error about broken packages is ironic, since it's true (as snapd and all packages that use it are garbage), but not the way apt implies it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.