7

(Relating to Pair Bose QuietComfort 35 with Ubuntu over Bluetooth - seems to be "too old to response to")

This is really frustrating!

I am running Ubuntu 16.04 and am unable to get sound in the headphones. I have tried all suggestions above without success. I have had it working before I reinstalled Ubuntu, but unfortunately I have not noted how I made it working then. Now I can pair, at least from the Ubuntu side what it seems, but there is no voice in the headphones indicating that a pairing has been made and the sound is still coming out from the computer's speakers.

[bluetooth]# pair 04:52:C7:5F:CB:A9 
Attempting to pair with 04:52:C7:5F:CB:A9
[CHG] Device 04:52:C7:5F:CB:A9 Connected: yes
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 00000000-deca-fade-deca-deafdecacaff
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 00001101-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 04:52:C7:5F:CB:A9 Paired: yes
Pairing successful

[Joachim Bose QC 35]# connect 04:52:C7:5F:CB:A9 
Attempting to connect to 04:52:C7:5F:CB:A9
[CHG] Device 04:52:C7:5F:CB:A9 Name: Joachim Bose QC 35
[CHG] Device 04:52:C7:5F:CB:A9 Alias: Joachim Bose QC 35
Connection successful
[Joachim Bose QC 35]# info 04:52:C7:5F:CB:A9 
Device 04:52:C7:5F:CB:A9
Name: Joachim Bose QC 35
Alias: Joachim Bose QC 35
Class: 0x240418
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Vendor specific           (00000000-deca-fade-deca-deafdecacaff)
UUID: Serial Port               (00001101-0000-1000-8000-00805f9b34fb)
UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
UUID: Bose Corporation          (0000febe-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v009Ep400Cd0134
[Joachim Bose QC 35]# 
4
  • 1
    Have you selected the headphones in System Settings > Sound?
    – wjandrea
    Commented Dec 1, 2017 at 6:59
  • They are not there! The only thing I have there is the built-in sound
    – Joachim
    Commented Dec 1, 2017 at 8:31
  • Please edit to include results for pactl list short | grep blue
    – Jeremy31
    Commented Dec 1, 2017 at 12:35
  • eperjoa@elxa6gwlq72:~$ pactl list short | grep blue 8 module-bluetooth-policy 9 module-bluetooth-discover 10 module-bluez5-discover
    – Joachim
    Commented Dec 3, 2017 at 18:30

1 Answer 1

0

I have a similar issue with a bluetooth (BT) headset, my solution was:

  • Open bluetooth (BT) manager (it should show a list with all BT defined)
  • If yours is not there,
  • Set the headphones(hp) to 'discover mode' and run a Search on the BT manager This should discover the hp and they should appear now. They may not connect though, in that case:
  • Right-click on the hp name and select headset, this may still not produce sound,
  • Right-click again on the hp name, this time there will be a new option, 'audio profile'
  • Select High Fidelity Playback (A2DP sink)
  • Now open your 'Sound Settings' and select your headphones and adjust volume.

Hope this helps.

2
  • 1
    The headphones are there, but there is not context-menu when I right click the hps. They are shown with a Bluetooth symbol on the right. Before I have seen it has had a headphone symbol. Not that I know if that makes any difference anywhere in the system...
    – Joachim
    Commented Dec 17, 2017 at 10:16
  • I got some hint to update bluetoothctl (I think); spinics.net/lists/linux-bluetooth/msg69764.html. But I cannot find out how to do that... any idea?
    – Joachim
    Commented Dec 17, 2017 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .