Since I installed 11.10 I am unable to copy large files (say 1gb or more) to ANY usb drive that is formated as FAT. The file starts copying, but soon an error appears, saying

"Unable to Copy" . "Error splicing file: Input/output error".

I am able to do it via terminal, using the cp command. I use Gnome3, but the same error has happened in Unity as well.

Apparently it works if I format the USB drive as NTFS or EXT3, EXT4. But, for many appliances, FAT is necessary.

The problem is also not with the USB port, because it works under Windows.

It did not happen before, when I had 10.04 installed.

  • Are you sure that the problem is not with files larger than 4gb, because that is the maximum size a file can be on fat32. – psusi Jan 24 '12 at 18:43
  • when you say Gnome3 and Unity, did you mean nautilus instead? – Alexandre Jan 24 '12 at 18:49
  • yes, nautilus, i mean. I enforced gnome3 and Unity, because i saw someone sugesting that it could be a problem with Gnome3. – yurividal Jan 24 '12 at 22:27
  • AND YES, im sure... i have tryed several files... including a 700MB avi video, and a 2gb mkv video – yurividal Jan 24 '12 at 22:28
  • well... it does not seem to be a bug with Ubuntu. I have the same versions installed on my LG notebook, and the same files copy smooth to the FAT USB drive... any ideas??? – yurividal Jan 24 '12 at 22:55

This is not about ubuntu. This is about file systems. Fat32's partitioning is different from New Technology File System (NTFS) or EXT. Because the partition sizes are different, you "can" have trouble about moving files to FAT32 from newer partitions.

Additionally, you can use


to convert your FAT32 driver to NTFS without data lose under Windows, CMD. But don't forget that; you won't be able to revert.

  • as i said, the problem is not only with FAT partitions. I have the same issue when copying files to a NTFS folder that is in my LAN. And terminal command works smooth... – yurividal Apr 10 '12 at 1:43
  • What about you RAM? – Hilmi Erdem KEREN Apr 10 '12 at 1:46
  • 4gb of DDR2 ram – yurividal Apr 10 '12 at 2:00

The problem seems to be the file size not the type of usb device. I was trying to copy a vmware image over to my home directory and I received the "Error splicing file: Input/output error".. I then tried a 3 meg file. That copied over with no issue. I then split the vmware disk image into 10 meg files. This worked like a charm. I know this does not solve the problem but it does get you a work around until it's worked out. Just a note.... my file copy stopped at 62.7 meg each time. The total file size is about 700 meg.

  • any success?? still cant find a solution – yurividal Apr 10 '12 at 14:34

Problem seems to be solved after upgrade to 12.04 precise

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.