0

I already have a working Canon MP990 insalled on Ubuntu 14.04. Im replacing it with an MG6865.

Ive installed (dpkg) cnijfilter2-5.20-1-deb.tar (which I used alien to convert from an rpm.

In Printers, add printer, I 'Find Network Printer'. It finds what it calls MG6800, listing it as IPP network printer via DNS-SD. It hten searches for drivers, and asks me to describe the printer. It then asks me to print a test page.

After that, the printer properties are displayed, with a device URI of dnssd://Canon%20MG6800%20series._ipp._tcp.local/

The printer state is listed as idle - rendering completed. Yet nothing is printed. Same happens with print test page.

Looking at the print queue, it's empty.

However if I go back in and try another test page, it then changes its mind and says 'cant find printer. Printer not connected?'

Im not sure where to look for the problem. Does it mean my driver isnt installed correctly, or its the wrong one? Or is the uri incorrect or the way I set up the printer settings not right?

Where do I start?

Can anyone help me trouble this please? (remembering I Have a working MP990 attached, and its settings look similar save the uri of course)

0

I would use the drivers that Canon supply; they come in a debian package so what Ubuntu uses; go here http://support-asia.canon-asia.com/contents/ASIA/EN/0100690202.html to download; select SAVE and it should end up in your Downloads folder as cnijfilter2-5.20-1-deb.tar.gz

then open a terminal; copy each command below; line by line; and paste each separate command into the terminal; and hit the ENTER key

cd Downloads
tar -zxvf cnijfilter2-5.20-1-deb.tar.gz
cd cnijfilter2-5.20-1-deb
sudo ./install.sh

the last command runs an install script; it should do the needed for you; how is the MP990 connected please? I sense the MG6800 series device is wireless: am I correct?

6
  • Thanks for your reply. When I installed this package, it warned I was downgrading the one already installed (which I had also got from the Canon site but as described in my post). However, once downgraded the printer worked! I never managed to get the install script (with any of the packages I downloaded) to work, they all complained they couldnt determine my OS type and/or that there were dependent packages missing. However, it prints just fine now so all is good thanks. Now onto scanning, which is proving similarly problematical! – colic Dec 5 '17 at 2:01
  • so for scanning you could 1) install the Canon package and 2) help the open-source guys at SANE: as your MG6800 is listed as untested; for Canon go here support-asia.canon-asia.com/contents/ASIA/EN/0100690502.html and download what will be scangearmp2-3.20-1-deb.tar.gz and the format is as above for the printer driver but substitute scangearmp2-3.20-1-deb.tar.gz in the tar line; and then cdscangearmp2-3.20-1-deb then run the install script; and to test it is working scangearmp2 is the command in the terminal; if all good, one can set up a launcher ... to launch ScanGear – pdc Dec 5 '17 at 8:06
  • if you join the SANE mailing list here lists.alioth.debian.org/mailman/listinfo/sane-devel and the guys would be delighted to have your help: you have the hardware; they have the expertise!! Let us know how it goes – pdc Dec 5 '17 at 8:07
  • OK, taht all worked well thanks. saane could not find the scanner, but all woth scangearmp2. That's what was throwing me (ie sane not finding it) – colic Dec 7 '17 at 7:48
  • great it is working; please do contact the SANE guys as they would really appreciate your help: you have the hardware they would like to hear about – pdc Dec 7 '17 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.