I'm running Ubuntu 17.10 with gnome on a Lenovo B40-70. This install is actually an in-place upgrade from Ubuntu Gnome 17.04 that I did the day 17.10 came out. After that, I never needed to go into the Bios, except today, when I went into the Bios to boot into a LiveCD, because it wasn't showing in the Fn + F10 Boot Options. There I realised that I can't change any Bios settings at all. When I change settings, they never get saved. I reboot to the Bios again, and the settings are the same as they were before. I should point out, these aren't the default settings. I actually tried to reset to default settings, and even that didn't get saved. Also, it seems like I can't boot from any USB drives. I have tried with a number of distros(multiple versions of ubuntu, Arch, manjaro) and they never show up in the boot options.

Then, I tried getting into the Bios from Grub, but it shows me this error - Error: could not set EFI variable 'OsIndications'

I'm not sure if these are Ubuntu issues, and whether these 2 issues are inter-related, but searching around, I found these 2 questions -

These look very similar to the issues I have, and I don't have enough reputation to comment, so thats why I'm making this question.

Edit: It seems like a lot of people are facing this issue - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147


A workaround I ended up using for a similar issue (warning, ugly): Turn power off. Remove hard drive. Power-on. In my case the BIOS defaulted to looking for a USB boot in the absence of a hard drive. Then, as soon as USB starts to boot, plug the hard drive back in to stop it throwing a "No HDD!" fit.

Told you it was ugly. Worked though.

  • In my case, even bootable USB drives aren't visible in the boot options.
    – Guest1997
    Nov 30 '17 at 17:56

Any updates? I have seen a case here, the guy have managed to make it work again by upgrading kernel to a newer version.

Unable to make changes in BIOS after 17.10 installation


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.