15

On Ubuntu 11.10, when on battery, the screen dims after 10 seconds of inactivity. This is annoying because it is too short. Is there anyway to increase this timeout?

I know I can disable it, but that is not what I want.

3 Answers 3

16

This command should set the time to 60 seconds:

gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time 60

In earlier Ubuntu versions, this setting can be found with the gconf-editor under gnome-power-manager. See also this thread.

5
  • 4
    I'm absolutely comfortable using the terminal (and this worked great for me by the way), but I sure do wish Ubuntu 11.10 let me change these kind of things through the "System Settings" GUI...
    – blong
    Feb 17, 2012 at 0:01
  • There's no reason this shouldn't be configurable through the GUI settings.
    – apdnu
    Jul 23, 2012 at 16:16
  • 1
    gconf-editor does not exist in newer Ubuntus any more. Use dconf-editor instead.
    – Karl Frisk
    Nov 22, 2012 at 14:51
  • 2
    This answer no longer works as of Ubuntu 14.04. It reports "No such key 'idle-dim-time'". Some of us would like to be able to do this from a script (e.g. as a wrapper for something that's going to play video to the screen), so the GUI is not usable. See my answer below. Sep 16, 2014 at 18:24
  • This is no longer actual, newest ubuntu doesn't have this key. See BobDoolittle's answer May 16 at 18:25
9

The answer marked above from 'lumbric' no longer works for Ubuntu 14.04.

If you need to do this from a command (e.g. for a script wrapping something that plays video), you now need to run:

gsettings set org.gnome.desktop.session idle-delay <seconds>

also useful in such a case might be disabling the screen lock:

gsettings set org.gnome.desktop.screensaver lock-enabled false

3
  • 1
    Thanks, also `gsettings set org.gnome.desktop.screensaver lock-delay <seconds>"
    – Bohr
    Jun 28, 2015 at 11:35
  • @Bohr: useful. But if I were writing a wrapper around something that played video, I might not know how long it is. So I'd probably disable it first, and declare a "trap 0" function that re-enabled it on exit, using 'gsettings set org.gnome.desktop.screensaver lock-enabled true'. That way it would disable the screen lock exactly as long as I need it to be. Of course that's vulnerable to signals that can't be handled, like SIGKILL but that's unlikely in practice. Jun 9, 2016 at 22:32
  • Works like a charm in 22.04! This should be accepted anwesr nowadays May 16 at 18:28
1

In 12.04, the setting using GUI now exists via System SettingsBrightness and Lock.

1
  • 6
    I'm using 12.04, all updates installed, and there's no setting to set the screen dim timeout in "Brightness and lock". The only "timeout" option on the "Brightness and lock" settings menu is to turn the screen off, which is not the same thing as dimming its brightness.
    – amfcosta
    Sep 13, 2012 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.