1

I get a black screen after booting with Ubuntu 17.10 and Nvidia. Seems a quite common problem already mentioned in many posts.

I have tried all options posted here and here , but nothing worked (each one individually and all options altogether)

• In /etc/gdm3/custom.conf: uncommented "WaylandEnable=false"

• In /etc/default/grub:` add at the line GRUB_CMDLINE_LINUX_DEFAULT the parameter "nomodeset" or “nvidia-drm.modeset=1” (in both case I kept “quiet splash security=selinux selinux=1”)

• reinstalling the drivers after and as follow

sudo apt purge 'nvidia-*'

sudo apt install linux-headers-$(uname -r)

sudo apt install nvidia-384 ** Also tried with nvidia-387

Checked if an old version of compiler (update-alternatives –config gcc) but gcc v7.2.0 is the only one I have

• The BIOS is set to use only PCI-E card video

Note:

I can load Ubuntu successfully when I use the generic (recovery mode) only, but not the normal one.

My Nvidia card is GTX1080Ti.

This issue started after upgrading from 16.10 to 17.10.

The booting time is increasingly slower, lagging at loading initial ramdisk (may be unrelated)

1

It has been widely reported that none of the proprietary nVidia drivers work with Wayland yet. So you have the choice of running 17,10 on Xorg or, if you want to use Wayland, purging all of your nVidia drivers and relying on the kernel Nouveau driver for your nVidia GPU

  • 1
    thank you for your answer. I thought uncomment WaylandEnable=false triggers run on Xorg, but that didn't work. Could you elaborate the steps about the Nouveau driver ? – Jean-Paul Abbuehl Nov 30 '17 at 10:08
  • There is an open source nVidia driver built into the kernel. If you purge all of the proprietary drivers your GPU should use this driver. When I installed 17.10 I got a menu on gdm whereby I could choose between Wayland and Xorg, don't you have this? You can find out whether you are running Wayland or X by using the command "echo $XDG_SESSION_TYPE" – SteveInBavaria Nov 30 '17 at 10:19
  • I run on x11 (Xorg), but still have this issue. When I installed 17.10, I didn't get this option. Maybe because I updated from 16.10 – Jean-Paul Abbuehl Dec 4 '17 at 14:48
0

I have a MSI laptop with a GT 645M GPU. I needed to install the NVIDIA drivers along with the CUDA toolkit so I proceeded to do this and all seemed to be normal until I rebooted my laptop...A black screen appeared!

I tried everything with no success:

  • the .Xauthority method
  • the nomodeset method
  • etc...

Until I discovered (by accident) the solution!! (YES!!)

I replicated the error and the solution after I found it!

1.- Install Ubuntu 14.04 2.- Install CUDA Toolkit (7.5 in my case)

  • Don’t Reboot If you did, then you may see the $·%·in’ black screen. (don’t worry)

2.- (I discovered this by accident) Partial Solution

  • Close the laptop lid and wait until it suspends OR Push the suspend button
  • Init back again your laptop and voila! (it worked for me)
  • If you don't have a suspend button or lid (desktop computer) you have to perform the next steps using the command line mode which you can access when being on the blackscreen with Ctrl+Alt+F1

3.- (I was working doing this by months until…) Full Solution

  • I first installed snap

  • I then installed snapd (yes with a ‘d’ ;) )https://docs.snapcraft.io/core/install-ubuntu

  • After installing these, the system required me to upgrade again (apparently these snap and snapd detected some new stuff) which I did.
  • Reboot the system

    It worked perfectly with no black screns, login loops etc. :)

  • I know It worked on ubuntu 14 but it may work as well on 17... I hope so – José Pablo Sanchez Jan 11 '18 at 19:59
0

I did upgrade from 17.04 to 17.10 some time ago. I was running on Xorg mode, not wayland, with the kernel Nouveau driver. The blank screen I did only get when closing and reopening the lid.

I did have the same issue with 18.04 later one.

By trying to install the nvidia driver manually over terminal I did find the real reason for this issue (I think so anyway :-) ).

Nvidia did provide a new driver version. That got installed with normal system updates. But this driver had problems with some dependencies.

So I found there are two options to solve this issue: 1. remove the buggy nvidia driver and change to another driver for your video card 2. get a newer driver from nvidia if one is available

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.