2

I have installed Discord on my Ubuntu 16.04 and I run it via terminal:

discord

And it's working fine, but on the top of the screen it says my installation is corrupted and I should fix it. There's also a "Help!" button which upon click, just opens a new empty web browser window.

Anyone know how I can fix my installation? I have tried reinstalling it and it's still the same.

4 Answers 4

8

To fix this "issue" make sure that you have all dependencies installed, especially libatomic1.

'libc6',
'libasound2',
'libatomic1',
'libgconf-2-4',
'libnotify4',
'libnspr4',
'libnss3',
'libstdc++6',
'libxss1',
'libxtst6',
'libappindicator1',
'libc++1',

Try installing the libatomic1 library, worked for me:

sudo apt install libatomic1

I personally used sudo dnf install libatomic, but on Fedora. Source (reddit)

4
  • Thanks! ` sudo apt-get update` ` sudo apt-get install libatomic-ops-dev` Is this how you install that library?
    – Zap
    Jan 24, 2019 at 13:51
  • 2
    Well personally, I did as mentioned in my answer sudo dnf install libatomic but I'm using Fedora so I suppose sudo apt-get install libatomic should do the job for Ubuntu.
    – Rymcode
    Jan 24, 2019 at 18:29
  • 1
    Thank you very much! I had the same problem on Centos 7 and resolved it with the corresponding sudo yum install libatomic and all was good after that. Jun 14, 2019 at 16:01
  • Fixed Discord for me on Void Linux. sudo xbps-install -S libatomic May 12, 2021 at 3:41
2

Deleting the Discord config folder worked for me:

rm -r ~/.config/discord

If you're afraid to delete the folder you can just rename the original folder:

mv ~/.config/discord ~/.config/discord_backup

Then close any open discord instances and open it again.

It will log you out, but it will go back to normal after you log in.

1

On Ubuntu 16.04 I've tried everything: purging the installation, deleting the config dir, installing the dependencies mentioned in other posts, using the *.tar.gz version, but the only thing that got rid of the error message was to uninstall everything and install the SNAP version.

I removed the old installation and configuration:

pkill Discord
rm -r $HOME/.config/discord
apt-get purge discord

installed the SNAP version:

snap install discord

started Discord from the KDE launcher and logged in, and the red banner was gone.

0

Open a terminal and run this command:

sudo apt --fix-broken install

This worked for me in Elementary OS, as it check and install dependencies for the corrupt package. It works with all those sudo dpkg -i packageName as dpkg doesn't install any dependencies, but it keeps registry that apt can get and fix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .