2

Yet another Touchpad issue but I've been reading countless posts and blogs on the subject, I can't find a solution to my problem.

I recently bought an ASUS FX503VD and it comes with Windows 10. I want to install Linux to be my main OS, but I have issues with the touchpad, it works perfectly well on Windows but not on Linux. I tried Mint, Ubuntu, Elementary and Fedora. I have the same problem on all of them, both in the Live version and after install.

This might be anecdotal but I have a GTX1050 graphic card which caused problem when installing, I got around it by using the following parameters in the grub script: acpi=off nouveau.modeset=0 xforcevesa. Once I got it started and installed the NVIDIA drivers, all is fine on this side. I do not have these params in the grub script anymore.

Now to the touchpad issue. At first it was not recognized at all, I added the i8042.kbdreset=1 param in the grub and it is now recognized. However it lack smoothness. It is a little like if something was interfering with it, that is the pointer will follow the finger but then stop for a few milliseconds and follow again. Also when touching the touchpad, it sometimes relocates the pointer before following the movement, instead of following the movement from the current position of the pointer. It also sometimes blocks when I click something. It is usable, but very annoying.

I tried this drivers on my current install (which happens to be Mint) https://github.com/mishurov/linux_elan1200_touchpad It works and the touchpad is now recognized without the need to have the i8042 param in the grub. But the smoothness issue remains.

I do not have the mouse plugged in, so it is not interfering.

Here is my xinput listing

$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ITE Tech. Inc. ITE Device(8910)           id=13   [slave  pointer  (2)]
⎜   ↳ ELAN1200:00 04F3:303E Touchpad            id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control               id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=9    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ Sleep Button                              id=11   [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD           id=12   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=15   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]

I also upgraded the kernel to the latest (currently 4.13.0-17) but the issue persists

$uname -a 
Linux nicolas-FX503VD 4.13.0-17-generic #20~16.04.1-Ubuntu SMP Mon Nov 6 14:18:00 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Not sure what to do now to get it working nicely. Any input will be greatly appreciated.

closed as off-topic by Charles Green, karel, vidarlo, Eric Carvalho, Zanna Jan 2 '18 at 12:41

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Charles Green, vidarlo, Zanna
  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Upgrading to Mint 18.3 greatly improved the situation. Still not perfect yet as the mouse keeps getting stuck in Firefox mainly, but the cursor is now smoothly following the finger mouvments. Probably due to the new libinput support in Mint 18.3. see linuxmint.com/rel_sylvia_cinnamon_whatsnew.php – Bentaye Dec 3 '17 at 9:33