0

This question already has an answer here:

On my main machine, I installed some fonts manually, by copying them to /usr/local/share/fonts/ amd then running sudo fc-cache -fv as sudgested in this answer. Now some askubuntu sites look like this:

enter image description here

and I cannot see the posts I write. Are the two events related? Or, how can I arrive at the bottom of this? Using another Firefox profile on the same machine, does give me the same problem.Using chrome however does not.

enter image description here

I have tried clearing the cache in the browser. I also reinstalled fonts by running:

sudo apt install --reinstall $(dpkg -S /usr/share/fonts/truetype | cut -sd: -f1 | tr -d ,)

as suggested in an answer to this question.

marked as duplicate by Bruni, Community Dec 5 '17 at 8:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • can you post the list of fonts returned by this command fc-list – bistoco Nov 28 '17 at 15:33
  • @bistoco That is a rather long list...735 lines. How should I add that without making the qquestion unreadable? Or, what am I looking for? – Bruni Nov 28 '17 at 15:38
  • This are the fonts that the page uses for the code blocks Consolas,Menlo,Monaco,Lucida Console,Liberation Mono,DejaVu Sans Mono,Bitstream Vera Sans Mono,Courier New,monospace,sans-serif. – bistoco Nov 28 '17 at 15:46
  • Ok, Menlo, Monaco, Lucida Console,monospace,sans-serif are not in the output of fc-list. Does this mean I uninstalled them for some reason? BTW in chrome the site is displayed properly./ Where can I find those fonts? – Bruni Nov 28 '17 at 15:51
  • 1
    Is that FF57? I had problems too with it. There was a bug, I think it's fixed in 57.0.1. This bug page has more details. IIRC I had to clean up the directories my fonts were in as they were in unusual places and the sandboxing was thus interfering with them. – pbhj Dec 4 '17 at 22:02

Browse other questions tagged or ask your own question.