0

There are a few NFS won't mount on boot! questions on AskUbuntu already, but I never had any problems 'till I upgraded to Ubuntu 17.10.

The NFS entries in my fstab are as follows:

192.168.1.2:/media/tardis /media/tardis nfs auto,nofail,noatime,nolock,intr,tcp,fsc,actimeo=1800 0 0
192.168.1.2:/media/bridge /media/bridge nfs auto,nofail,noatime,nolock,intr,tcp,fsc,actimeo=1800 0 0
192.168.1.2:/media/scratch /media/scratch nfs auto,nofail,noatime,nolock,intr,tcp,fsc,actimeo=1800 0 0

This is what I get in the syslog:

Nov 28 12:50:17 stormwind systemd[1]: Mounting /media/tardis...
Nov 28 12:50:17 stormwind systemd[1]: media-tardis.mount: Mount process exited, code=exited status=32
Nov 28 12:50:17 stormwind systemd[1]: Failed to mount /media/tardis.
Nov 28 12:50:17 stormwind systemd[1]: media-tardis.mount: Unit entered failed state.

Any idea what changed and how to solve it?

  • I really doubt this would help but, just in case, try changing the nfs value in your fstab file to nfs4. Also try running sudo mount 192.168.1.2:/media/tardis /media/tardis does that work? Any error messages? – terdon Nov 28 '17 at 12:36
  • Right, forgot to mention: running sudo mount -a just works after booting. I'll try the nfs4 option – skerit Nov 28 '17 at 12:45

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.