1

I am on Ubuntu Mate 17.10 and sometimes I am using pulseaudio through network. Also I am using an equalizer module for pa. So I have 3 ouput sinks: my notebook sound device, eq sink and remote sink on my net device:

pavucontrol screenshot.

Every time I start pulseaudio (on boot or on pulseaudio -k) my default output sink is my remote device, however I have switched default sink to my notebook device. I tried to add this two lines to /etc/pulse/default.pa:

set-card-profile 1 output:analog-stereo+input:analog-stereo
set-default-sink alsa_output.pci-0000_00_14.2.analog-stereo

that should set up my notebook sound device as default sink, but it changes nothing.

How can I make pulsaudio remember my choice, or, at least, set my notebook device as default output?

  • Do you have another default.pa in ~/.pulse or ~/.config/pulse that overrides your system defaults? – Takkat Nov 28 '17 at 7:33
  • No, I definitely have not. – bergentroll Nov 28 '17 at 9:55
2

Problem

Personally, I have many sources and sinks and since upgrading to Xubuntu LTS 18.04.1, the selected default source and sink happened to be the wrong ones.

One can set the "fallback" output and input device in pavucontrol by means of a darkened check mark —which is not very clear to any user!!! This did not help much as these settings are temporarily of nature and are lost with every reboot.

Listing all available audio interfaces

$ pactl list sinks short
$ pactl list sources short

Test setting PulseAudio defaults

$ pactl set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
$ pactl set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo

Permanently setting the defaults

$ sudo gvim /etc/pulse/default.pa

### Make some devices default
set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo
  • 1
    Thank you! This helped a lot, nothing else worked.... here is a small correction though: sudo gvim /etc/pulse/default.ca -> should be sudo gvim /etc/pulse/default.pa – davidhq Nov 21 '18 at 17:48
0

To debug this please try with the following steps

  • Remove any custom lines from your default.pa (after a backup of course)
  • Delete the ~/.pulse or ~/.config/pulse directory to get rid of unwanted remnants.

    mv ~/.pulse ~/.pulse.old
    mv ~/.config/pulse ~/.config/pulse.old
    
  • Copy the default.pa to your HOME ~/.config/pulse to be able to edit it without root privileges.

    cp /etc/pulse/default.pa ~/.config/pulse/
    
  • Restart the pulseaudio server with

    pulseaudio -k
    

Before inserting lines into ~/.config/pulse/default.pa test if they work to be able to read errors:

  • List sinks to have their index and names correctly and be able to copy & paste them

    pactl list sinks short
    
  • Set profile as desired:

    pactl set-card-profile <index|name> output:analog-stereo+input:analog-stereo
    

    Debug this line if you get an error. Note that a sink index may change if you have volatile sinks, better use a name in this case.

  • Make a sink default

    pactl set-default-sink <sink_name>
    

Only if all above commands succeeded without an error you can insert the commands into the ~/.config/pulse/default.pa which on the next restart of pulseaudio or after you restarted your session will override system-wide settings. Hopefully your default sink is then loaded by default.

  • I made all you wrote. Now I have only three custom lines in my ~/.config/pulse/default.pa: uncommented "load-module·module-esound-protocol-tcp" and "load-module·module-native-protocol-tcp" on lines 77-78 and after them "load-module·module-equalizer-sink". Also I had need to install paprefs and check "Make discoverable PulseAudio network sound devices available locally", because without of this there is no my network device in sinks. Now pa remember default sink if I check some and make "pulseaudio -k". However on but I still get my network device as default sink in any ways. – bergentroll Nov 28 '17 at 14:13
  • there is a file in ~/.config/pulse folder with filename ending "-default-sink". File is plain text so can open it to check it has correct name, and edit to change name if needed. – nik gnomic Dec 10 '17 at 1:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.