1

I am on a computer using Windows 7, service pack 1.

On the host Windows system, I have done the following:

  • I have installed Oracle VirtualBox Version 5.2.0 r118431 (Qt5.6.2).

  • I have used VirtualBox to create a 32-bit Ubuntu server virtual machine, using all default settings.

  • I have created a folder on the Windows host system at the path C:\sharedFolder.

  • I have configured a shared folder in VirtualBox for the Ubuntu server virtual machine called "sharedFolder" at the path C:\sharedFolder. (Not auto-mount, not read only.)

  • I have loaded the 32-bit Ubuntu server virtual machine with Ubuntu 17.10 32-bit server, creating a guest Ubuntu system.

On the guest Ubuntu system, I have done the following:

  • I have installed the VirtualBox Guest Additions for Linux using the following command:

    sudo apt-get install virtualbox-guest-additions-iso

  • I have created a group called "vboxsf" and confirmed that my user is a member of that group.

  • I have created a folder in my home folder called "shared_folder" with permissions set wide open to 777.
  • I have ATTEMPTED to mount the shared folder "sharedFolder" designated in VirtualBox to the "~/shared_folder" folder in my home directory using the following command:

    sudo mount -t vboxsf -o uid=1000,gid=1000 sharedFolder ~/shared_folder

This ATTEMPTED mount command has failed every time with the following error:

mount: /home/<user_name>/shared_folder: mount(2) System call failed: Protocol error.

I have attempted to perform the mount with Sharing turned off and Sharing wide-open on the folder at C:\sharedFolder on the host Windows system.

What am I doing that is causing the mount command to fail?

  • 2
    Have you tried the automount option under the menu item Devices/Shared Folders/Shared Folders Settings? – Organic Marble Nov 28 '17 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.