1

When I try install FileZilla to Ubuntu I have this message:

filezilla: Depends: filezilla-common (= 3.25.1-1~getdeb1) but 3.25.1-1~getdeb1 is to be installed
       Depends: libgcc1 (>= 1:3.0) but 1:6.0.1-0ubuntu1 is to be installed
       Depends: libstdc++6 (>= 5.2) but 5.4.0-6ubuntu1~16.04.5 is to be installed

I tried everything I could and whatever I tried to give me the same result

add Getdeb repository:

sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu xenial-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'

install the key:

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

For those who don’t have a previous release installed, just run commands to update package index and install FileZilla:

sudo apt update    
sudo apt install filezilla

I get this error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 filezilla : Depends: libgnutls30 (>= 3.5.3) but 3.4.10-4ubuntu1.4 is to be installed
W: Target Packages (apps/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target Packages (apps/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target Packages (apps/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target Translations (apps/i18n/Translation-en_GB) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target Translations (apps/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target DEP-11 (apps/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
W: Target DEP-11-icons (apps/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5
E: Unable to correct problems, you have held broken packages.
3

It's difficult to write a good answer because I don't know how badly you have messed up your system. But, the goal is to get rid of the getdeb ppa you have added, and install Filezilla from the official repos.

This warning

 Target Packages (apps/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/getdeb.list:2 and /etc/apt/sources.list.d/getdeb.list:5

probably means that you've added the getdeb ppa more than once. This is the first thing that needs to be fixed.

Open "Software and Updates" and click the "Other Software" tab. Now look for duplicate entries in the list of ppas that have checkmarks besides them. Uncheck all entries that are related to the getdeb ppa. Enter your password when required.

When you are done, click Close. A box will pop up telling you that you need to refresh the software sources. Click the Reload button. If you get errors at this point, something is still wrong with the list of ppas. Go back and fix the list.

Once you have completed this part of the task, you need to remove any software that actually got installed from these ppas, if any. For the sake of brevity, I will assume that none did.

Now that your list of software sources is fixed, you can install Filezilla using sudo apt install filezilla

If your system is more messed up than I assumed, come back and edit your question to include any additional error messages that you received.

1

A command line centric method. The rm command assumes that /etc/apt/sources.list.d/getdeb.list is the only source of the offending package list. Depending on the state of your system apt-get install --fix-broken may or may not be.

sudo rm /etc/apt/sources.list.d/getdeb.list
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install --fix-broken
sudo apt-get install filezilla

Note: This solution will create obsolete/locally installed packages. User can find them with the following command:

dpkg -l | grep getdeb

After that user can reinstall those packages from official repositories.

1

You might have filezilla-common installed with the old getdeb version:

sudo apt remove filezilla-common
sudo apt install filezilla

Worked for me, 2nd command reinstalled filezilla-common with the latest dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.