Well, this is fun.

I have a couple of .ods files, password protected. After installing last Ubuntu updates, including Libreoffice 3.4.5, I can no longer open those files.

I'm using 11.10 x64 Oneiric. Fortunately, my old Ubuntu with the 10.04LTS and Openoffice 3.2 can open those files.

I tried a workaround. I removed the password from the .ods files using Openoffice, moved the files on Oneiric and tried to save them with a password. The error I get is interesting: General Input/output error.

Does someone has the same problem after the last Libreoffice/Ubuntu update? Before I was perfectly able to open those files.

  • the same here. This is obviously a bug, so you should file a bug report on libreoffice instead of asking this on askubuntu. – xubuntix Jan 24 '12 at 12:36
  • Not so obvious since it happen after the Ubuntu Package Update. And I can't find similar problems in Libreoffice Forum ;) – lokutus25 Jan 24 '12 at 12:42
  • well, it is definitely a bug. maybe not in the main libreoffice repository but in the ubuntu package. – xubuntix Jan 24 '12 at 12:46
  • 2
    For what it's worth, there's a post at nabble.documentfoundation.org/… from a xubuntu user and a response from someone who is part of the LibO team. – user25656 Jan 24 '12 at 15:03

Happened to me too following an update to 3.4.5.

I also run 3.4.5 at work on a Win XP installation and this issue isn't there so it's either Linux centric or a Ubuntu packaging problem.

I only have 1 password-protected file (ironically it contains all my passwords which I'm in the process of moving to keepassx) but it was irritating nonetheless. I got round it by installing calligra suite which will open them. No good for sharing with MS users as it won't save in word format, but at least you will be able to open the files and re-save them with passwords if you stick with odf.


A bug has been submitted.



Seems the Bug will not be addressed. Anyway there is a workaround, as described in launchpad: purge and reinstall libreoffice. I did it and worked for me. Hope this can help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.