3

So I have looked this up and can only find solutions for older versions of Gnome.

Everywhere quotes this as the solution:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.nemo.desktop show-desktop-icons true

Which worked on on older versions of Gnome (such as the version available with Ubuntu 16.04LTS) but so far nothing is working on the most recent. I would like to replace Nautilus with Nemo, allowing Nemo to produce desktop icons (home folder and rubbish bin) as well as being able to drag my cursor along the desktop to highlight things.

My current Ubuntu version is 17.10 Gnome 3.26.1 Nemo 3.4.7 Nautilus 3.26.0

I have had no luck on both Wayland and Xorg.

Thanks in advance to any comments and solutions.

5
  • 1
    I believe you need to first set nautilus not to show desktop icons , gsettings set org.gnome.desktop.background show-desktop-icons false , set nemo as default file manager, xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search & then set nemo-desktop to autostart. (- maybe if you run nemo-desktop once that would suffice, don't remember)
    – doug
    Nov 27, 2017 at 23:03
  • Personally I use nemo as the default file manager but leave nautilus to handle the desktop, best experience for me in 17.10/18.04 (- though I'm using unity..
    – doug
    Nov 27, 2017 at 23:05
  • @doug I never set nemo-desktop to autostart! Do I just enter that into start-up applications then restart the desktop?
    – AdLinux
    Nov 28, 2017 at 7:27
  • 1
    Yeah, try setting in start-up apps one with the command of nemo-desktop, reboot & see what happens..
    – doug
    Nov 29, 2017 at 0:03
  • @doug This solved it, please write what you wrote as an answer and I will tick it as solving the problem,
    – AdLinux
    Nov 29, 2017 at 7:45

1 Answer 1

5

Setting up Nemo in 17.10:

To set Nemo as the default file manager simply run in a terminal:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

To also set Nemo to handle the desktop run this command to unset Nautilus from handling the desktop:

gsettings set org.gnome.desktop.background show-desktop-icons false

Then open Startup Applications and click Add. In the pop up window use any Name you wish and use this as the Command:

nemo-desktop

Click Add, then log out and log in again or reboot (many times gdm3 requires a reboot).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.