3

On Ubuntu 17.04, I had CompizConfig set up so that Ctrl+Alt+Key pad number would place the current window into the appropriate quarter/half of the screen.

This is not working after upgrading to 17.10. I've tried changing the Grid and Put settings in Compiz but nothing seems to take effect.

In addition, I have an external monitor connected to my laptop and now Ctrl+Alt+4 and Ctrl+Alt+6 move the window from one monitor to the next. I want the window to remain on the current monitor.

How can I get this back?

Update: I'm using GNOME display environment. I had Wayland setup by default after the upgrade but disabled it due to another issue I was experiencing.

1
  • GNOME does not use Compiz under Xorg nor Wayland. If you want to continue using Compiz, you'll need to switch to a different environment that uses it. I wouldn't recommend Unity, as it is no longer supported, and expected to be removed from 18.04 though. I'm not sure what other environments rely on Compiz today. – dobey Nov 27 '17 at 19:25
1

I switched to Unity and everything went back to normal.

sudo apt install unity

Then restart and at the login screen, click the settings gear icon and select "Unity".

My system was running terribly slow with GNOME and now it's speedy again as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.