1

I've been using my ubuntu laptop (Dell XPS13) for years and was just using it last night with no problems. This morning when I turned on my laptop and logged into my account, I found that all the unity menus and dash launchers were missing. No keyboard shortcuts worked (such as CTRL-ALT-T to open a terminal).

I was able to open a terminal window via the right-click menu on the desktop. I manually restarted Unity by executing $ unity on the command line. This resulted in a blank grey menu bar flashing momentarily across the top of the screen, but it did not fix the problem.

Unity does work if I login as the guest account instead of my normal account. This prompted me to try uninstalling the fluxgui applet from my normal account, but that did not fix the problem.

For now I've switched to GNOME Flashback (Metacity) instead of Ubuntu (default) for my desktop environment via clicking on the icon next to my login name at the login screen. This at least allows me to do anything at all with my computer.

Any ideas why this is happening or how to fix it?

  • What about re-installing unity desktop? – George Udosen Nov 27 '17 at 19:28
1

I fixed the problem by blowing away some stuff in ~/.cache. Specifically I renamed these 4 folders in ~/.cache:

apturl-gtk
com.canonical.certification.checkbox-touch
compizconfig-1
com.ubuntu.checkbox

Then restarted Unity with $ unity and saw that Unity launched correctly. I attempted to narrow down which one of the four solved the problem by restoring each folder one by one, but I was unable to recreate the original problem /shrug

My colleagues suspect that compizconfig-1 was the culprit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.