0

I have an Python Executable which has to be launched with sudo Rights on Start up. Things i Tried:

  1. a.Added the Sudo rights in /etc/sudoers sudoer file

    b.Added the Path in the Startup Application GUI Startup Application on reboot Application is Launched but without Sudo Rights

  2. created a Launch script to launch the application and added the Script in /etc/rc.local rc.local file Launch script

After Reboot nothing happens. When i run the Launch script individually it runs.

  • 1
    What Ubuntu version are you on? 17.10 uses Wayland by default, which does not permit sudo/root GUI applications from running in the user's session. – Thomas Ward Nov 27 '17 at 14:39
  • currently am using Ubuntu 14.04... – Kishore Avinash Nov 28 '17 at 6:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.