Ive installed openstack 2.3.1 (Mitaka) using conjure-up on a single machine(Ubuntu 16.04 Sever). My lxd container uses zfs as a storage backend which is 4TB in size, so there is enough space.

I could launch a test instance by using the image which came along with the installation

Flavor Name m1.small

Flavor ID ee64beb2-e13b-454a-b085-3916947c96d1

RAM 2GB

VCPUs 1 VCPU

Disk 20GB

The size of this image is 124.94 MB

Disk Format is RAW

The network specs for this image are

subtestnet1 190.168.1.0/24 (gave some random range)

This is a private network, so when launching the instance the assigned IP for the is 190.168.1.4

I shutdown this instance , since I just wanted to test If i can launch.

Now, I try to launch my custom vdi image(Ubuntu 16.04 with some software) which is 12GB in size with the below specs

Disk Format RAW

subtestnet1 190.168.1.0/24 (gave some random range)

Flavor Name m1.medium

Flavor ID dbda6460-bdf0-4387-9e05-0ebf7a26f45a

RAM 4GB

VCPUs 2 VCPU

Disk 40GB

But it just hangs in spawning state (its been almost 30 minutes)

Ive checked the logs in nova-compute node but it didnt show any error log. I checked in nova-cloud-controller/0 and there were some error logs in the files below

nova-api-os-compute.log

2017-11-27 03:18:43.276 23931 ERROR nova.api.openstack.extensions [req-3095878e-c8d3-4ba6-9c44-ad7dabde21fe a048e14509c84c0f9205819fb29a2501 003ad069faba48709198af746c92b5fa - default default] Unexpected exception in API method: MessagingTimeout: Timed out waiting for a reply to message ID 9fdb48d40a1046b2ad7b63b2703df928

nova-conductor.log 2017-11-27 04:29:30.123 23928 ERROR nova.conductor.manager NoValidHost: No valid host was found. There are not enough hosts available.

NoValidHost: No valid host was found. There are not enough hosts available. 2017-11-27 04:29:30.177 23928 WARNING nova.scheduler.utils [req-dc65dc2a-0bf0-4376-b8ba-88fd788ad233 a048e14509c84c0f9205819fb29a2501 003ad069faba48709198af746c92b5fa - default default] [instance: 4a7c771d-65a7-4369-97c0-d432630c24d7] Setting instance to ERROR state.: NoValidHost_Remote: No valid host was found. There are not enough hosts available.

I've restarted all the nova related services on the compute and controller nodes but didn't help.

Has anyone faced such an issue?

Any help to debug further will be appreciated. If you need more info, do let me know.

Thanks.

I was never able to launch an instance on conjure-up lxd openstack if it was something other than an lxd image. I then started using devstack instead which got rid of a lot of these 'issues'.

When I had to wait more than 10 minutes during instance launch it was due to the flavour I had assigned to the instance. The vdi image was 8GB in size, I gave it 50GB disk space and after 30 minutes I got an error saying the 50 I assigned was too little, it needed 129GB minimum.

If it takes too long on creation I just stop it and gave it more space.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.