1

LTS Xubuntu 16.04.3 (64-bit) hangs while installing in VirtualBox 5.2.0 r118431 (Qt5.6.2) on Windows 10. See screenshot. The latest Lubuntu and TinyCore worked fine, (but respectively lacked consistent resolution and popular package support) so it's not a VirtualBox issue. I tried pressing escape and clicking stuff, but nothing moves aside from the animated busy cursor. The idle screen blanking also works.

Xubuntu 16.04 hangs while installing in VirtualBox

  • Did you check the hashsum? – Panther Nov 26 '17 at 20:34
  • @Panther I'm assuming uTorrent already did, as it's seeding the iso on my wired 200/20 Mbit connection. – Cees Timmerman Nov 26 '17 at 22:08
0

You should be able to find out what's going on by pressing CTRL-ALT-F1 inside the VM. That should bring you into a console. Try out ALT-F(any of the function keys) inside the console.

There should be different consoles showing different things, among others some debug output on what the installer is doing. You should be able to find out what it's doing or respectively where it's stuck by looking around there.

Also there should be a shell there. You should be able to issue a ps auxw or similar to find out what's going on.

  • I've already reset and am reinstalling with different settings, but will try to redo my original course tomorrow. – Cees Timmerman Nov 26 '17 at 21:31
0

I've reset the VM and with these different choices it appears to be installing:

  1. Try Xubuntu instead of Install to disk.
  2. Don't download updates while installing.
  3. Don't use LVM.
  4. Don't encrypt home folder.

The slideshow completed and right now it's "Copying files...". Pressing the arrow to the left of that status shows it's failed to load module "overlay-scrollbar" but the progress bar goes on, slowly. Attempting to load the display settings to up the resolution to see the full details leads to a segfault:

Slow install and segfault while checking display settings

The crash report details contain the correct time, but the task bar time is an hour behind:

Task bar hour behind correct crash report time

At 21:54 (actually 22:54) installation completed and i continued to test the display settings again. Same internal error. Sent error report again and restarted the system. Pretty animated splash screen asks to remove installation medium, but apparently VirtualBox already did. Entering a jarring black screen with one text line, occasionally interrupted by the splash screen. Logging in to a very clean desktop... And there are the 3 icons and wallpaper. Trying display settings again... Same internal error. Oh well, at least it supports deb at more than 640x480.

  • After installing the VirtualBox Guest Additions from the CD and restarting, the resolution fit the window and the display settings work. – Cees Timmerman Nov 26 '17 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.