I have a 8 month old Lenovo X1 Carbon (5th generation) which was originally running 16.04LTS.

When I upgraded to 17.04 I noticed the battery is no longer charging. When the AC is plugged in battery indicator / upower / Power Statistics all show the battery as "charging".

However the battery doesn't charge - it just stays at it's current rate (38%). Using the laptop when it's not plugged into AC just depletes the battery further.

I have tried three different chargers with the same results. I doubt there is any physical issue with the battery as the laptop is relatively new & the issue has only just started after the upgrade to 17.04.

Any help appreciated.


Same situation here, but my battery died completely and I could not turn laptop on at all. Called Lenovo tech support and their awesome rep (Joshua) instructed me to do a "static reset." Steps are:

  • Unplug laptop;
  • insert end of paper clip in small hole on bottom of laptop;
  • hold for five seconds; let go; plug laptop back in;
  • hit power/start button.

Worked like a charm! Apparently, electricity builds up inside laptop with nowhere to go. Reset button on bottom releases it so battery can recharge as it should. Thank you, Joshua!

  • 1
    I'm confirming this approach worked on a five-month old Thinkpad X1 Carbon (6th gen) aka "X1C6". Symptoms started 10 mins ago w Ubuntu's power notification alternating between "charging" & "not charging" while the LED charging light was dark indicating "not charging". Went from 10% to dead in a few mins. After doing a few rounds of 5-second paper-clip presses in that small hole on the back (could feel a smell "click") eventually I could get the LED light to turn red (indicating charging) and the notebook would boot up. Thank you Marta for sharing this - you spared me lots of time & stress :)
    – HenrikB
    Dec 18 '18 at 2:46
  • Electricity is not "building up". All modern battery packs contain both cells and control circuitry to manage how cells are charged and discharged and to protect the cells from damage. What you are doing is resetting that circuitry (which can be thought of as a little computer) so that it allows the cells to be used again.
    – user459652
    Feb 28 '19 at 17:16
  • 1
    It worked on my X1 Carbon 7th gen. Thanks a ton!! Jul 5 '20 at 18:42
  • Worked on X1 1st. gen. too! Thanks!!
    – Jeremy
    Jul 12 '20 at 21:45
  • Worked on X1 carbon gen 7 too :) Nov 6 '20 at 14:46

This worked for me:

  1. Shutdown computer
  2. Pressed power button to turn it on & pressed F1 to enter BIOS
  3. In BIOS go "Config" > "Power" > "Turn off Battery"
  4. After computer has turned off I unplugged AC & plugged it back in again.

The laptop is now charging.

Not the answer you're looking for? Browse other questions tagged or ask your own question.