0

I have installed Ubuntu desktop 17.04 to Thinkpad T470p recently. I have been hard time adjusting speed and sensitivity for the trackpoint.

With default setting track pointer was really slow and bring up mouse speed in mouse speed in setting didn't increase speed much

so I changed values in these files but I needed to bring sensitivity up to max 255 to get what I want but now it's too sensitive and it wiggles when I bring a point to a button or text.

/sys/devices/platform/i8042/serio1/serio2/sensitivity /sys/devices/platform/i8042/serio1/serio2/speed

What is the reason for not being able to adjust speed for T470p?? Anybody has similar issue??

Thanks

  • did you try to use gnome-tweaks? in keyboard and mouse option you can set it to acceleration profile > adaptive then proceed with settings > devices > mouse , and adjust it there – Yien Nov 27 '17 at 7:40
0

I was facing the same problem with my T460P. Took me four hours today because I am completely new to Linux.

My solution was:

1 - Find optimal settings by changing the values in /sys/devices/platform/i8042/serio1/serio2/speed and sensitivity.

In order to make the settings be still there after reboot,

2 - Generate the file in /etc/profile.d/trackpoint.sh with the following lines:

#! /bin/sh 
echo "255" | sudo tee /sys/devices/platform/i8042/serio1/serio2/speed
echo "255" | sudo tee /sys/devices/platform/i8042/serio1/serio2/sensitivity

Replace the numbers with your settings.

3 - Type sudo visudo.

Add the line >>ALL ALL = NOPASSWD:/etc/profile.d/trackpoint.sh<< to the end of the file to allow every user to execute your script without root password

4 - Add the following line to the end of ~/.profile:

sudo /etc/profile.d/trackpoint.sh

I hope this is also the solution in your case. Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.