2

Followup to an earlier question on having my encrypted disk auto-decrypt on startup. It seems I completely shut myself out of my system, I'm getting a kernel panic on startup.

Here's what I did:

First I added a trivial password abc123 to unlock my partition using

cryptsetup luksAddKey /dev/sda3

Then I followed exactly these steps ("How I did it on Ubuntu 16.04.3"). Note that I inserted sudo where appropriate.

That is:

  1. appended ,keyscript=/root/lukspw at the end of the line in etc/crypttab that contains sda3_crypt (.....) none luks (sda3 is the disk for which I was prompted during startup to enter the decryption password)

  2. Created the file /root/lukspw with the content:

    #!/bin/sh
    printf "abc123"
    

    and made it executable: sudo chmod +x /root/lukspw

  3. And finally:

    sudo update-initramfs -u -k`uname -r`
    

I did not get any errors during any step of the process.

Now upon reboot, either in normal or 'recovery' mode (through the Advanced option at startup) I get this:

error

And I can't do anything, no interaction, no response on keyboard activity.

Have I done something terrible? Is there still a way out of this?

  • Can you boot using an older kernel version from GRUB's Advanced options? The sudo update-initramfs -u -k`uname -r` should only have modified the latest kernel you were running, older kernels should still boot into the normal password prompt. – Byte Commander Nov 25 '17 at 12:09
  • No, there is only this one (4.4.0.87), and the same in recovery mode. – RocketNuts Nov 25 '17 at 12:11
  • Can you boot from a Boot Repair disk and share its diagnostic output with us? I'm not sure this will contain anything useful due to the encryption, but I don't really have a clue what else to try at the moment, I'm afraid. – Byte Commander Nov 25 '17 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.