1

I installed Ubuntu Server 16.04.3 (kernel version 4.4.0.87) in a VirtualBox Virtual Machine. No fancy settings, pretty much just a straightforward default install.

After the installation was finished and I booted the first time, I was unable to login ("login incorrect").

After some attempts in disbelief, I assumed I must have made a typing mistake during the installation, so I just installed the whole thing again. Same problem. I was now convinced something was fishy, so I reinstalled it again, took extra care and triple-checked every step, making 100% absolutely certain I am entering the right username and password everywhere.

During this last installation I made screenshots of the installation process. Click on each image for the full resolution version:

  1. Specifying the username:

    username
    (Click images to enlarge)

  2. Specifying the password:

    password

  3. Confirming password:

    confirm password

  4. After installation was finished, booting my freshly installed Ubuntu:

    login

I am absolutely 100% sure I am entering the exact right details. No dumb mistakes like keeping caps lock on or mistakenly using a Dvorak keyboard or anything.

What am I doing wrong?

(edit) I also tried the 'recover lost password' procedure. Note that this doesn't really apply here, I didn't lose my password, I'm 100% sure, see screenshots from installation. Nonetheless I tried this anyway, going in rescue mode and root prompt, and when I do: passwd kenneth
To my surprise I get: passwd: user 'kenneth' does not exist

Again, note that I'm 100% sure that I specified my username kenneth during the installation.

Then I did: more /etc/shadow and I get a list of typical system user accounts, like root, daemon, bin, sys, and so on. But no 'kenneth' account nor any other that looks like a user account, only the typical system accounts. In fact there are none with an actual password, they all have ! or * for the password hash.

I also did ls -al /home, nothing there.

What could be the reason for an Ubuntu installer to not create the user account as specified during the installation?

Note that I didn't get any errors during the entire installation, everything worked smoothly and straightforward from beginning till end.

  • Reset it from the rescue mode! – George Udosen Nov 25 '17 at 3:54
  • Possible duplicate of How do I reset a lost administrative password? – George Udosen Nov 25 '17 at 3:55
  • 1
    @George Thanks, tried that, but to no avail. See also the added section to my post. – RocketNuts Nov 25 '17 at 6:58
  • May be a reinstall would be in order if this is fresh install – George Udosen Nov 25 '17 at 12:05
  • @George I have already attempted to reinstall several times. This problem keeps coming back (see also post, my description and screenshots were already from the third time I reinstalled it). – RocketNuts Nov 25 '17 at 12:09
0

So, this is a bug, but you can avoid it. Add user in rescue mode. Make uid of that user = 1000. Check /etc/shadow to be sure all done well. Reboot and have fun.

# adduser --uid 1000 username

If uid 1000 is used already, then just add user with uid above 1000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.