I used to use an extension to hide/show the title bar in Firefox, but since Firefox 57 was released most of the extensions were disabled.

In Chrome I just uncheck the option "Use system title bar and borders" and it's done.

Are there any ways to do that?

  • You can merge the title bar of maximised application windows with the Activities bar at the top following this answer. – pomsky Nov 25 '17 at 1:22
  • Thanks but I am using Kubuntu, altough KDE Plasma has an option to remove the title bar the maximize, minimize and cloase button disapear that makes it annoying. – Jamo Nov 26 '17 at 18:34

Update - May 2018

Firefox 60 has now been released to all users with support for Client Side Decorations. Go to Menu > Customise and uncheck Title Bar in the bottom left corner. This works in all distributions to my knowledge, although apparently it looks a little strange still in KDE.

You can check your browser version by going to Menu > Help and selecting About Firefox. If you are not yet on Firefox 60, you should be able to update through your distribution package manager or by downloading it directly from Mozilla.

The information below here is probably irrelevant unless you are on an older version of Quantum such as 57, 58, or 59.


Enable Client Side Decoration

If you are willing to switch to Firefox 59 (currently available on the Nightly channel), it supports a very rough prototype of CSD, or Client Side Decoration, which allows the browser to render its tab list where the title bar would normally be. This reduces the amount of window chrome at the top and probably gives the effect that you are looking for.

CSD on FF57/Fedora

On newer builds of Firefox Nightly, CSD can be enabled by going to Menu > Customise and unchecking Title Bar in the bottom left corner.

On older builds of Firefox Nightly, this option may not be present, and as such you may need to use the following method.

  • Navigate Firefox to about:config
  • Search for the property widget.allow-client-side-decoration and set it to true
  • Reboot Firefox

Right now, this feature comes with the caveat that it may not work correctly on all systems. It certainly works on Fedora, and while is not working right now on my Ubuntu 17.10 PC there have been recent articles showing it working fine. If not, new Nightly versions are pushed out (unsurprisingly) every night so you can expect a fix very soon.

  • Thanks...but that means that is not possible to get in Firefox 57, right? – Jamo Nov 24 '17 at 23:44
  • 3
    It odds how Chrome has make it done from a while and Firefox is still trying to do it. – Jamo Nov 26 '17 at 18:34
  • 1
    It is odd how Ubuntu Quantum has no title bar on Unity (integrated with top bar), but on Gnome You can't hide it... – Jakub Kopyś Dec 1 '17 at 12:01
  • 1
    The widget.allow-client-side-decoration property doesn't appear to be present anymore, but there's a GUI element to do the same thing: omgubuntu.co.uk/2017/11/firefox-nightly-adds-csd-option – Mike Lawrence Jan 11 at 0:10
  • 1
    Funny enough, it works on Fedora with Firefox 58 but not on Arch on the same version. There, it doesn't have the titlebar checkbox, regardless of client-side-decoration. – burny Feb 6 at 18:43

On Gnome Shell you could also use No Title Bar extension.

In Firefox 61 about:config there is an option browser.tabs.drawInTitlebar. One can just set it to true.

This will solve you problem! https://addons.mozilla.org/en-US/firefox/addon/hide-title-bar/ Be sure to install Python script (details in addons page after installation). also install wmctrl package.

Firefox Title bar is boring specially on small screens.

  1. First add this: https://addons.mozilla.org/en-US/firefox/addon/hide-title-bar/
  2. go to Firefox > tools > add-ons and click on more link and at the very bottom click on go to install page and download the .deb file and install.
  3. sudo apt install wmctrl
    Reboot.

Worked for me.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.