In earlier releases I could do that by right-clicking on a document file, going to Properties -> Open With and selecting Abiword, but in 11.10 I can't see Abiword as an option. How can I now make it the default application for opening my doc/docx files?

Screenshot of file properties' Open With tab


you can try installing ubuntu-tweak http://ubuntu-tweak.com/ In Admins->File Type Manager in Text and Program Section select the filetypes that you want to change to handle with Abiword

| improve this answer | |
  • Awesome! I already had Ubuntu tweak for its Janitor function but never ventured into other "tweaks" it stores. Your suggestion answered my query..Thanks alot! – subeh.sharma Jan 24 '12 at 7:05

Another way might be to click the Add button and add the executable's path.

See, xxx@linux-dopx:~/> which oocalc gives me /usr/bin/oocalc This path if added by the Add button will appear in that list, and then you can select it.

| improve this answer | |
  • but in that image, the add button is grayed out. :-( I always much prefer Abiword and Gnumeric over Libre or Open Office. The fact that Libre has the truely open source aspect is great, but it sticks out like a soar thumb lol hopefully the Libre team will be able to make it look a little more native and pretty looking in coming versions. – Daniel Clem Jan 27 '12 at 11:34
  • @DanielClem You said: but in that image, the add button is grayed out. Perhaps because the root permissions are needed? – Aquarius_Girl Jan 27 '12 at 11:37
  • Well I really dunno lol Maybe launching Nautilus as root using 'gksu nautilus' and then opening the preferences of the file and doing the same thing?? As a very new user, I was just starting to catch onto stuff like that back in Maverick 10.10, but now it seems all this stuff is changing. I would try and test it, but I'm using Xubuntu which uses slightly different apps for most stuff. Its annoyingly inconsistent. But doesn't have Unity, and is so much more customizable. – Daniel Clem Jan 28 '12 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.