0

I am attempting to install a driver for the TPLink AC600 under Ubuntu 16.04 as outlined in the Answer at this link:

TP-Link T2U (AC600) usb WLAN adapter driver on Ubuntu 16.10

When running the make command, I get one warning that the frame size of 2040 bytes is larger than 1024 bytes, but no errors.

When I attempt to run the insmod command I get the following error message:

insmod: ERROR: could not insert module mt7610u.ko: Unknown symbol in module

Can anyone help me with this please?

Following are additional items as requested by chili555:

kevin@miner01:~$ uname -r
4.10.0-40-generic
kevin@miner01:~$ modinfo ~/Downloads/mt7610u/mt7610u.ko
filename:       /home/kevin/Downloads/mt7610u/mt7610u.ko
firmware:       mt7650u.bin
firmware:       mt7610u.bin
description:    MT7610U 80211.ac usb driver
author:         Hans Ulli Kroll <ulli.kroll@googlemail.com>
license:        GPL
srcversion:     6BAF8B1220487A0F11B9919
alias:          usb:v0E8Dp7650d*dc*dsc*dp*icFFisc02ipFFin*
alias:          usb:v0E8Dp7630d*dc*dsc*dp*icFFisc02ipFFin*
alias:          usb:v2357p0105d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0DF6p0079d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pC711d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v20F4p806Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v293Cp5702d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v057Cp8502d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04BBp0951d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07B8p7610d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0586p3425d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3D02d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB31d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0DF6p0075d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17DBd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17D1d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp760Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp761Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pB711d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA711d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E8Dp7610d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13B1p003Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp7610d*dc*dsc*dp*ic*isc*ip*in*
depends:        cfg80211
vermagic:       4.10.0-40-generic SMP mod_unload

After installing the other driver listed in comments:

kevin@miner01:~$ iwconfig
enp0s31f6  no wireless extensions.

lo        no wireless extensions.

ra0       Ralink STA

This driver would not automatically connect on reboot. If I restarted the network manager using sudo service network-manager restart then the wireless adapter supposedly connected shortly afterward, but any attempt to actually use the connection failed.

  • I also tried manually adding mt7610u.ko under the /lib/modules/$(uname-r)/kernel/drivers/net/wireless/mediatek tree, then running depmod and modprobe mt7610u. That seemed to run without any errors, but when I inserted the USB wireless device I got a system error reporting dialogue, and the same thing happened again after rebooting. So then I ran modprobe -r mt7610u, removed mt7610u.ko from the /lib/modules/... tree, and ran depmod again. Now back to where I started... – kamyers1 Nov 24 '17 at 19:29
  • Please edit your question to add the result of: uname -r and also: modinfo ~/mt7610u/mt7610u.ko – chili555 Nov 24 '17 at 19:49
  • Additional items added to original question per your request. – kamyers1 Nov 24 '17 at 20:07
  • I also tried the driver version provided here: github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes , and got further. But I can't yet see how to establish a wifi connection. Do I need to do something that sets my adapter as "managed"? – kamyers1 Nov 24 '17 at 20:09
  • Does it show something other than Managed in iwconfig? Frankly, after many experiences with this device, I doubt that you will ever get is to work by any means. See my post #18 here: ubuntuforums.org/showthread.php?t=2367163&highlight=mt7610u – chili555 Nov 24 '17 at 20:23
0

Upgrading kernel to version 5.0.5 the adapter will work without any third part driver installation.

Here are the steps:

First of all: make backup of all your system and files.

Open a terminal and do the following commands:

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-headers-5.0.5-050005_5.0.5-050005.201903271212_all.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-headers-5.0.5-050005-generic_5.0.5-050005.201903271212_amd64.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-headers-5.0.5-050005-lowlatency_5.0.5-050005.201903271212_amd64.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-image-unsigned-5.0.5-050005-generic_5.0.5-050005.201903271212_amd64.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-image-unsigned-5.0.5-050005-lowlatency_5.0.5-050005.201903271212_amd64.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-modules-5.0.5-050005-generic_5.0.5-050005.201903271212_amd64.deb \\ https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0.5/linux-modules-5.0.5-050005-lowlatency_5.0.5-050005.201903271212_amd64.deb
sudo dpkg -i  linux-headers-5.0.5-050005*.deb  linux-image-unsigned-5.0.5*.deb  linux-modules-5.0.5-050005*.deb

After installation:

sudo reboot
uname -a

Tested on Xubuntu 19.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.