2

I used to use my Epson scanner, back when I was running Ubuntu 17.04. Since I upgraded to 17.10, though, XSane and Simple Scan just can't find it. It shows up on lsusb, and I've downloaded and installed Epson's drivers, but it's just not working. I know the scanner and usb cable are good; it works fine with my MacBook Air. Can anyone help?

  • Same for the V33 scanner, it seems. :-( – Sam Wilson Jan 10 '18 at 8:26
4

I just upgraded to Ubuntu 17.10 and experienced the very same problem like the op; however, I was able to fix it for me in four steps:

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane
sudo vi /etc/udev/rules.d/79-udev-epson.rules

contents:

ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777"

sudo ln -sfr /usr/lib64/sane/libsane* /usr/lib/x86_64-linux-gnu/sane/
reboot

See also https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012

2

I fear that this is a known bug. See https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012

Although they're referring to 18.04 that's the same version of libsane1 as in 17.10 and the change to sane appears to have stopped various Epson scanners from working.

  • This is not an answer to the question. Please open your own questions. Meanwhile wait until you have enough reputation for commenting on questions. – derHugo Nov 30 '17 at 16:10
  • 1
    So why not do something helpful like pointing me to where the guidelines for posting here can be found? – Paul Oldham Nov 30 '17 at 16:46
  • Clicking on Help (at the bottom of the page) – derHugo Nov 30 '17 at 17:23
  • 2
    @derHugo IMHO, if there is a bug in libsane preventing the use of a scanner, this will be a valid answer to give to this question. – Videonauth Nov 30 '17 at 20:37
  • 2
    Although, for the record, it turns out that the first version was fine too according to the page he directed me too which said "Still no answer to the question, and you have the same problem? Help us find a solution by researching the problem, then contribute the results of your research and anything additional you’ve tried as a partial answer.", which is what I did. Shrug, whatever, this is why I don't come here unless desparate, it's not a very welcoming place. – Paul Oldham Dec 1 '17 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.