18

Last time I decided to use Ubuntu 17.10. When I installed Skype from official site of Skype (I downloaded the .deb package) I can do almost everything without one important feature for me. I can't share my screen while I am talking with somebody. On Windows that was working perfectly, on Ubuntu I don't even see such a option.

My friend has the same version of Ubuntu, GNOME and Skype. He can use that feature. I can't and I can't figure out why.

1
  • My friend has THE SAME version of ubuntu, gnome and skype. He can use that feature. I can't and I can't figure out why. Nov 24, 2017 at 13:07

4 Answers 4

20

If you use Wayland (Ubuntu 17.10) and latest version (v8.11.0.4) of skypeforlinux screen sharing is not working.

In order to have screen sharing working you can switch to Xorg as explained here.

Otherwise you can use Google Hangout, where you can even share windows.

1
  • You are right. Thanks for help. I changed Wayland to Xorg and it works perfect. Nov 28, 2017 at 15:19
7

This is because ubuntu 17.10 switched from Xorg display server to wayland.(Why wayland). But many applications are yet to port to wayland. many of the existing applications do not work properly with wayland. Skype is also such a case.

To switch from wayland to Xorg (X11). Do the following

  • Log out from the current session
  • then select Ubuntu on Xorg from the login screen enter image description here
  • Make sure you have an X11 Session by executing the following command in terminal.

    echo $XDG_SESSION_TYPE

it should output x11

now your Skype screen sharing will work

6

The latest version(s) (v8.x.x.x onwards) of skypeforlinux (.deb package downloaded from Skype website) has the screen-sharing option (only in an Xorg session, if you're in a default Wayland session you'll have to switch to an Xorg session first).

You can access this option by clicking on the + symbol (More Options) at the bottom while making a video call:

enter image description here

4
  • Version Skype'a 8.11.0.4 Version of module speach 2017.23.01.38 And I don't see any share screen... Edit: Gnome 3.26.1 Ubuntu 17.10 Nov 24, 2017 at 13:04
  • Key part for me was, that you need to make a video call before this option is available. In other words: If you don't have a webcam you can't share your screen. I have no idea who's responsible for this IMO stupid decision at Microsoft :(. Apr 11, 2018 at 7:25
  • I'm using Skypeforlinux on Ubuntu 19.10 on an Xorg session and still I don't have any share screen option.
    – To Do
    Mar 13, 2020 at 8:10
  • Yeah, 2 years later... Ubuntu 19.10. XOrg or Wayland - screen sharing is greyed out in conf. calls
    – SuAlfons
    Apr 5, 2020 at 12:32
0

You can use web skype (web.skype.com). Enter skype web site and login to skype from the web it is exactly like the app and everything works normally there. Note: It works on chrome for now.

3
  • It works normally if you're in an Xorg session. The problem was different, Ubuntu 17.10 came with Wayland as the default instead of Xorg. Screen sharing doesn't work on Wayland due to its security restrictions.
    – pomsky
    May 6, 2020 at 7:55
  • I have Ubuntu 18. Web.skype solved sharing problem for me.
    – zaher
    May 7, 2020 at 8:10
  • Yeah, because Ubuntu 18.04 and later releases comes with Xorg as the default session instead on Wayland. Read this: omgubuntu.co.uk/2018/01/…
    – pomsky
    May 7, 2020 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.