6

I have the following system:

$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 17.10
Release:        17.10
Codename:       artful

$ gdm3 --version
GDM 3.26.1

I would like to disable the user list in GDM and enter my user name and password to log-in. I have already searched a lot but did not find any valuable solution.

How can I achieve this?

8

This feature is currently bugged, see: https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1724944 and mark yourself affected

You need to install the dconf-editor tool if you not have already:

sudo apt install dconf-editor

Then when you opened it navigate to:

/org/gnome/login-screen

and set the 'disable-user-list' button to 'on':

enter image description here


Since the above is still bugged, the only solution is right now via terminal edit the following lines in /etc/gdm3/greeter.dconf-defaults:

#[org/gnome/login-screen]
# disable-user-list=true

to:

[org/gnome/login-screen]
disable-user-list=true

Be sure to edit both lines otherwise you might crash your login completely.

1

One option:

Edit /usr/share/gdm/greeter.dconf-defaults and remove "#" to uncomment the line:

disable-user-list=true

Another option:

Use gconftool-2 or gconf-editor. Change this value to true:

/apps/gdm/simple-greeter/disable_user_list

Reference

https://help.gnome.org/admin/gdm/stable/configuration.html.en
https://mike632t.wordpress.com/2016/05/28/gnome-3-customizing-the-login-screen/#userlist

  • 1
    See comment made at the other post. You also need to uncomment [org/gnome/login-screen] if you do it your way. Only doing your uncomment crashes the login. – Rinzwind May 30 '18 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.