Ive cloned my ubuntu installation, but cannot get grub2 to see it.

Before I had the install on /dev/sda1 and a grub boot prtition on /dev/sda2

I copied them both to a new disk - now boot prtition is on /sdb1 and the cloned partition (using gparted) is on /sdb2

Ive set the BIOS boot order ot boot from the driv ive copied to. At startup the first time it booted into the old install (this was expected, since I hadnt changed the grub entries)

But now, while in my 'old' installation, if I run grub-mkconfig it only finds the install on /dev/sda1, and not its copy on /dev/sdb2

Ive tried reinstalling grub from scratch but no joy....


You need to give the cloned partitions new UUIDs so they are not confused with the old ones. Run sudo tune2fs -U random /dev/sdb1.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.