2

I'm trying to install matlab r2017b. The installation process is done without any problems but now I can't open matlab. (In installation I chose the one it says I have a license file. I entered my license key but it did not ask for license file)

Preparing installation files ...
Installing ...
Finished
matlab
matlab: command not found
export PATH=/usr/local/MATLAB/R2017a/bin:$PATH
alias matlab=’LD_PRELOAD=/usr/lib64/libstdc++.so.6 matlab -desktop’
bash: alias: -desktop’: not found

I also tried to start license manager but it failed.

cd /usr/local/MATLAB/R2017b/etc/
/usr/local/MATLAB/R2017b/etc$ ./lmstart
bash: ./lmstart: No such file or directory
7
  • You just can't make it through modern engineering if you can't use matlab.
    – jdwolf
    Nov 24, 2017 at 3:46
  • @jdwolf any idea about how to make matlab work?!?
    – Mina Fa
    Nov 24, 2017 at 3:50
  • Have you already finished C?
    – jdwolf
    Nov 24, 2017 at 4:02
  • In all seriousness did you install via root? if not you might still need to chmod +x them.
    – jdwolf
    Nov 24, 2017 at 4:04
  • @jdwolf yes I installed it via root
    – Mina Fa
    Nov 24, 2017 at 4:16

1 Answer 1

2

You're trying to use typographic quotation marks in the shell interpreter which fails. I presume you copied that command from some web site and the author’s text editing tool or web content management system tried to be smart and converted the original plain quotation marks to make them prettier.

You need to replace them and use plain quotation marks instead:

alias matlab='LD_PRELOAD=/usr/lib64/libstdc++.so.6 matlab -desktop'

or

alias matlab="LD_PRELOAD=/usr/lib64/libstdc++.so.6 matlab -desktop"
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .