I have a dual boot Ubuntu 16.04 and Windows. In the past, it always worked fine. Now, when booting up Ubuntu as usual from the GRUB menu, the screen flickers between a line saying /dev/sda5/ clean, .../... files, .../... blocks and a loading screen of Ubuntu. I have waited ten minutes at occasions, but it still didn't load.

If I boot up Ubuntu but add nomodeset after the quiet splash, it just shows the line /dev/sda5 clean ... and nothing happens.

I tried starting from recovery mode, and then resumed. This gives [FAILED] Failed to start Clean up any mess left by 0dns-up

If I press Ctrl + Alt + F1, I can log in, and proceed as usual in a non-graphic environment.

This made me suspect there was something wrong with the driver. Indeed, the output from lshw -c video is rather odd: the configuration line says configuration: latency=0 as if there's no driver. Furthermore, lspci -kvnn, in the VGA compatible controller has no line Kernel driver in use:. It does have a line Kernel modules: i915.

Things I've tried:

From https://ubuntuforums.org/showthread.php?t=2072420 sudo add-apt-repository ppa:ubuntu-x-swat/updates # x-updates has been replaced by updates sudo apt-get install xserver-xorg-video-intel sudo vim /etc/X11/xorg.conf with the following text being put in the file: Section "Device" Identifier "Card0" Driver "intel" Option "AccelMethod" "sna" EndSection However, this didn't work: when rebooting normally, it would exhibit the same problems, and strangely, the xorg.conf file disappears.

So my question is: how can I get the Intel driver installed correctly?

  • 1
    Kernel modules: i915 means the driver is installed, as expected with Intel graphics drivers. The problem is somewhere else. – user692175 Nov 23 '17 at 18:26
  • @MichaelBay Do you know where this "somewhere else" might be? – Pim Nov 23 '17 at 18:28
  • Sorry, no idea. But you should check the logs (that I'm not sure which ones either and I'm not at my usual PC to check it out). – user692175 Nov 23 '17 at 18:30
  • @MichaelBay What kind of logs? I really don't know where to look – Pim Nov 23 '17 at 21:34
  • askubuntu.com/a/765320/692175 – user692175 Nov 23 '17 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.