I am trying to unmount google-drive-ocamlfuse. I entered the following command:

fusermount -u ~/google-drive

it returns:

fusermount: entry for /home/<user_name>/google-drive not found in /etc/mtab

What is wrong and how to fix it?

In general how can I uninstall ocamlfuse

  • 1
    Is it mounted in that location? – user692175 Nov 23 '17 at 16:28
  • @MichaelBay, yes it was, I mounted it using command: google-drive-ocamlfuse ~/google-drive. Whole my ubuntu is not very responsive now. – user1700890 Nov 23 '17 at 18:06
  • @MichaelBay, thank you for clarifying. How can I unmount it or remove it completely? – user1700890 Nov 23 '17 at 18:42
  • Try giving it the full path to where google-drive is actually mounted. – user692175 Nov 23 '17 at 18:45
  • @MichaelBay full path is /home/<user_name>/google-drive and when I issue command with this path, I get back the same error – user1700890 Nov 23 '17 at 19:05

Because you need mount folder first (in /home/user_name/google-drive):

# mount
google-drive-ocamlfuse ~/google-drive

An them umount:

# umount
fusermount -u ~/google-drive

PD: I recommend changing the name of the folder without symbols. Maybe "gdrive" or another similar


And it's even better to use a bash script described in the post Share Google Drive in Samba

# replace "user" with yout username unix account
# replace "gdrive" with your (path) GoogleDrive Folder

case "$1" in
    echo 'Mount Google Drive...'
    # Optional (If the folder does not exist)
    if [ ! -d $GD ]; then mkdir -p $GD && chmod 777 $GD; fi
    google-drive-ocamlfuse $GD
    echo "OK"
    echo 'Umount Google Drive...'
    fusermount -u $GD
    echo "OK"
  echo "Usage: ./gdmu {start|stop}"
 exit 1
 exit 0

Save as bash gdriveini (or any name you want) and execute (don't forget chmod +x gdriveini):

 ./gdriveini start
 ./gdriveini stop
| improve this answer | |
  • This is not an answer. I have the same problem and I can't unmount the drive – smartmouse Nov 10 '19 at 11:49
  • @smartmouse Have you tried the solution? Keep in mind that this is a recurring problem with fuse, no matter the application that uses it. Sometimes it happens when we pass a file to the cloud and cancel the operation before finishing or sometimes for other reasons. The point is that this application (or any other one that uses fuse) is not very reliable – ajcg Nov 11 '19 at 16:49
  • I have not dash or other symbols in the name of folder and I have just mounted and then tried to unmount the drive. I didn't any operation on files. – smartmouse Nov 12 '19 at 9:01
  • What message is displayed when you try to disassemble? (PD: please read this post maravento.com/2018/11/compartir-google-drive-con-samba.html) – ajcg Nov 12 '19 at 13:36
  • What do you mean for "disasseble"? If you mean unmounting I get the same error described in the question. The post you linked is hard to use since the quoted commands are plenty of spaces! – smartmouse Nov 14 '19 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.