0

I'm using iBus for Chinese pinyin input. The little top floating window with suggestions is placed in the lower part of the screen. Can I change it so that it instead always is displayed close to where I'm writing?


Version info:

Desktop: XFCE 4

$ ibus version
IBus 1.5.11

$ cat /proc/version
Linux version 4.10.0-38-generic (buildd@lgw01-amd64-059) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4) ) #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017

$ env | grep -E '_IM|XMOD'
CLUTTER_IM_MODULE=xim
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
QT4_IM_MODULE=ibus
GTK_IM_MODULE=xim
  • 1
    I tested with ibus-sunpinyin on Xubuntu 16.04.3 (Mousepad), and couldn't reproduce the behavior you describe. It works fine on standard Ubuntu as well. So it's hard to advise you. I'm not aware of any setting to control the location of the candidate window. – Gunnar Hjalmarsson Nov 25 '17 at 3:10
  • Btw, are the input method related variables set correctly, i.e. what does the command env | grep -E '_IM|XMOD' output? – Gunnar Hjalmarsson Nov 25 '17 at 4:50
  • Looks good, even if I'd have expected the GTK_IM_MODULE variable to be "ibus" as well. Unfortunately I'm out of ideas. – Gunnar Hjalmarsson Nov 26 '17 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.