0

I'm using Ubuntu 16.04 on a Lenovo Z50-70 system. When I choose to go into the suspend mode, it is successfully going into the suspend mode. But when I decide to wake the laptop from suspend, caps lock and num lock keys light up. But the laptop is not waking and screen continues to be off. This is my first day of using Linux. It will be great if anyone could help me with this issue.

1

Ran into the same thing with Ubuntu 17.10 on an Asus X550J laptop. Originally had upgraded from 17.04, tried to a clean install of 17.10. Tried all of the various driver suggestions; updating grub; etc. Finally found the solution -- BIOS settings.

On Asus computers you boot into BIOS settings by holding down the Escape key while the computer powers up. Once in BIOS tab to the Advanced settings and you'll see Wake on Lid Open and Power Off Energy Saving. I disabled both of those, rebooted, and now I can finally shut the lid on the laptop without it just powering off the system or getting frozen.

Your BIOS shortcut key and settings may differ but worth looking for something similar. Hope that helps someone else avoid some hair pulling.

  • For me it actually helped to disable NVidia graphics card. So If I need a performance mode, I will enable it in BIOS, but I don't really need it – rightaway717 May 2 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.