1

I'm trying to restore my Ubuntu following this guide.

I launched from Live USB and fdisk -l gives me this:

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D9704AB0-61E0-44CF-BE30-B9C95522AD76

Device        Start       End   Sectors  Size Type
/dev/sda1      2048  15624191  15622144  7.5G Linux swap
/dev/sda2  15624192  64452607  48828416 23.3G Linux filesystem
/dev/sda3  64452608  64647167    194560   95M EFI System
/dev/sda4  64647168 234440703 169793536   81G Linux filesystem

But when I execute

root@ubuntu:~# umount /dev/sda1

I'm getting umount: /dev/sda1: not mounted

  • According to fdisk's output /dev/sda1 is your swap partition. As those are not mounted by default umount's behaviour is expected and totally fine. What do you want to achieve? Maybe this helps: How do I disable swap? – dessert Nov 23 '17 at 22:02
  • 3
    Possible duplicate of How do I disable swap? – dessert Nov 23 '17 at 22:03
3

/dev/sda1 is apparently your swap partition. A swap partition doesn't get "mounted" so, as unmount is correctly telling you above: "/dev/sda1: not mounted".

Maybe you want to issue a mount on the command line, to see what is mounted.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.