1

I wish to install some extensions from https://extensions.gnome.org/. So here is a history of what I did. I install ubuntu 16.04.3 LTS. Successfully done. Now I installed gnome on it using the commands-

$ sudo apt update && sudo apt upgrade
$ sudo apt-get install ubuntu-gnome-desktop
$ sudo apt-get install chrome-gnome-shell

Last command just to ensure that it is installed (usually it is installed by default). I chose gdb3 on prompt while running the second command. Here are the info. with respect to the versions-

$ gnome-shell --version
GNOME Shell 3.18.5
$ firefox --version
Mozilla Firefox 57.0

Later on, I installed the firefox gnome-shell integration plugin from the firefox addons manager.

Even after logging out and rebooting, I am getting the following messages on firefox (my primary browser) and chrome respectively-

Firefox message:

enter image description here

Chrome message:

enter image description here

As a result, I can't install extensions from the site. Ask if any more info is needed. Please help!

  • 2
    Did you select GNOME session instead of Unity at the login screen? – pomsky Nov 23 '17 at 8:43
  • I did not get any option like that, but the login screen was not unity. – Harshit Agrawal Nov 23 '17 at 8:44
  • It was of gnome. – Harshit Agrawal Nov 23 '17 at 8:45
  • Output of echo $DESKTOP_SESSION? – pomsky Nov 23 '17 at 8:48
  • ubuntu. Now it looks like gnome-session is not running. – Harshit Agrawal Nov 23 '17 at 8:49
0

It looks like you have logged in to a Unity session instead of a GNOME session.

If you're using GDM3, there should be a cogwheel (⚙️) next to the "sign in" button at the login screen. Click on it and select GNOME instead of Unity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.