2

I am having a hard time trying to install Gnome Shell Extension: 'Gnome Global Application Menu. I am running Pop!_OS 17.10, and so far I've tried two different methods.

Method no. 1: I tried following the instructions given at GNOME Layout Manager. This consists of the following:

  1. sudo apt-get install unity-gtk2-module unity-gtk3-module
  2. zenity wget curl unzip
  3. wget https://raw.githubusercontent.com/bill-mavromatis/gnome-layout-manager/master/layoutmanager.sh chmod +x layoutmanager.sh ./layoutmanager.sh

However, phase two results into the following error message:

XXXXs@XXXXs:~$ zenity wget curl unzip
You must specify a dialog type. See 'zenity --help' for details

I decided to keep going anyway, but after the phase three, I have no idea what should happen / what should I expect / how should I proceed. Any ideas?

Method no. 2: I followed the following instructions given at Gnome Shell Extension: 'Gnome Global Application Menu. This consists of:

  1. Running via Terminal: sudo apt-get install unity-gtk2-module unity-gtk3-module
  2. Downloading the Extension from the very site (.zip file)
  3. Copying and extracting (updated) the .zip file to ~/.local/share/gnome-shell/extensions/ (for me, however, the extensions folder was missing, so I had to create it on my own)
  4. Restarting the shell by pushing Alt+ F2, and then writing r into the input field that emerges.
  5. As far as I am concerned, at this point I should activate the Extension through GNOME Tweaks. However, I cannot find anything relevant to the aforementioned process!

So, what should I expect to see at GNOME Tweaks? Did I do something wrong?

4
  • @pomsky thanks! I updated the post according to your comment. That's what I did actually, just expressed myself all wrong :-) – Jayaguru-Shishya Nov 22 '17 at 21:41
  • 2
    @Jayaguru-Shishya try to install any other non default extension from the extensions.gnome.org website (that can run without any other dependency). If you can not install/run it, you have a problem with your gnome instalation. If not, use the method 2 and in point 3, just copy the sub-folder "gnomeGlobalAppMenu@lestcape" and NOT the parent folder of the extension that say "....-master", to the ~/.local/share/gnome-shell/extensions/ directory. Restart your machine and try to enable the extension then. I hope this help you. – lestcape Nov 23 '17 at 18:27
  • @pomsky I just did what @letscape suggested above: moved gnomeGlobalAppmenu@letscape to ~/.local/share/gnome-shell/extensions/. It seems to have fixed the problem. Thanks anyway, both of you :-) – Jayaguru-Shishya Dec 2 '17 at 16:52
  • @Jayaguru-Shishya Oh, yes! Sorry, I didn't read letscape's comment carefully. I also though the same and that's why I asked for the output of ls ~/.local/share/gnome-shell/extensions/ and posted the answer just after you provided it. I should have asked letscape to post the answer instead! :( – pomsky Dec 2 '17 at 21:28
1

In case of method no. 2, if you extract the .zip folder you'll get a Gnome-Global-AppMenu-master folder. Placing this folder in ~/.local/share/gnome-shell/extensions/ won't work.

Inside the Gnome-Global-AppMenu-master folder there should be a gnomeGlobalAppMenu@lestcape folder. Place this gnomeGlobalAppMenu@lestcape folder inside ~/.local/share/gnome-shell/extensions/ instead.

4
  • Now when it finally works, however, I'd to advise the others to follow EXTREME CAUTION with this extension. Not all apps do support the idea of global menus, and opening for example LibreOffice, makes my fan sing Hosanna and COMPLETELY FREEZES my system. So, I guess I'll just go with the flow and swim with the rest of the GNOME stream :-) Unity days are gone ... for most, I think... – Jayaguru-Shishya Dec 2 '17 at 17:10
  • 2
    This is not your question, but basically gnome shell have a monolithic architecture and Libre Office is a big menu. The render of the global menu and the render of other things inside the compositor (with is also where Mutter it's runnig) will then run in the same thread and ofcurse this mean the thread will be saturate of tasks and your whole system will freeze. More info: github.com/lestcape/Gnome-Global-AppMenu/issues/67 – lestcape Dec 5 '17 at 2:46
  • @lestcape I gave the extension another shot, and as I enabled all of the features under the Support header (all of which are Experimental, by the way), my system does NOT freeze anymore after launching software like Libre Office! So, one of the features I enabled was actually called Use the extension as a replace of Gnome AppMenu. Not sure, but perhaps this has something to do with it...? Thanks anyway, and merry Christmas! :-) – Jayaguru-Shishya Dec 24 '17 at 15:54
  • @Jayaguru-Shishya merry Christmas to you! I don't know. I recently add a "fix" to this problem (is not a completely fix, because the problem is in the gnome side, but it will decrease the freezing a lot). So, is your configuration or is the fix that was introduced? github.com/lestcape/Gnome-Global-AppMenu/commit/… – lestcape Dec 24 '17 at 22:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.