0

Since upgrading to 17.10 I can no longer reconnect to the login screen in remote sessions using VNC. The only way I can reconnect to a remote session is if I am already logged in, then VNC is able to re-establish a session.

This is a problem when working from home if I need to reboot my Linux server or logout / switch users.

Doesn't VNC run before a user logs in?

I am using RealVNC as my VNC server/viewer and Cinnamon as my desktop environment. This combination worked with no problems until I upgraded from Ubuntu 17.04 to 17.10.

I have tried installing (re-installing) lightdm and then dpkg-reconfigure lightdm and selecting lightdm. This does allow me to access the login screen, but now my desktop environment is different from cinnamon.

Is there some combination that will allow me to access the login screen remotely and still have the cinnamon desktop environment?

  • Surely I can't be the only one to have experienced this. There must be a solution this out there? – Nolan Nov 24 '17 at 13:23
  • Well, it's been over week since I posted my issue. Isn't there anyone that can comment or suggest a resolution? – Nolan Nov 30 '17 at 14:58
  • What if you remove the login screen and make it automatically login. In that case, you will directly be presented with your desktop instead of stucking at login screen. I known we should not do auto login as it can be security issues but would it work. What do you think.? – S Andrew May 25 at 6:00
0

We have seen this behaviour as well... only fix/workaround we could find was to connect via a shell session and run "service lightdm restart" We have a suspicion that this behavior might be related to the power setting on the screen and/or screen lock.

| improve this answer | |
  • Thanks for your recommendation. I tried it, but the service fails. Also, I am using Cinnamon, so my desktop would not be the same if I logged in under lightdm. – Nolan Dec 11 '17 at 17:37
  • I also don't know if it is Ubuntu / Cinnamon that is not presenting the screen properly for ReavlVNC to detect it or if it is ReavlVNC that is not interpreting the login screen. I have not found anything on the RealVNC site relating to this, but I had no problem until the Ubuntu 17.10 upgrade. – Nolan Dec 11 '17 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.