1

I have installed Arduino IDE 1.8.5 I in my Laptop and in UBUNTU 16.04 LTS The option in Tools of PORT is grayed. I want to use Arduino Uno on it but i can't fix it.

2 Answers 2

0

I think it is permission issue as in similar answer.

Add your user to the appropriate group - dialout with the command below:

sudo usermod -a -G dialout $USER

then logout and login back.

1
  • 2
    i cant resolve it....
    – Robo Lover
    Nov 23, 2017 at 13:02
0

I solved following serial port related problems in ubuntu 18.04 as follows:

Problem 1 : Cannot open /dev/ttyACM0: Permission denied
Solution : Grant permissions to read/write to the serial port with this terminal command ---> sudo chmod a+rw /dev/ttyACM0 Here replace tty port with your respective ubuntu port.

Problem 2 : Failed to open /dev/ttyACM0 (port busy) Solution : This problem appears when serial port is busy or already occupied. So kill the busy serial port with command ---> fuser -k /dev/ttyACM0. Here replace tty port with your respective ubuntu port.

Problem 3 : Board at /dev/ttyACM0 is not available Solution : In this case your serial port in tools menu will be greyed out. I googled a lot for this, but I none of solution worked for me. Atlast I tried different arduino board and usb connector and it was working for me. So, if you are having old arduino board (can be solved using required drivers) or defected arduino board then only this problem arises.

1
  • The problem with Solution 1 is that, as soon as you unplug the Arduino, the permissions are forgotten and you will get the permission denied error again when you plug it back in. Nov 19, 2021 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.