5

I have on a Xubuntu 16.04 another Xubuntu 17 running in a VirtualBox. I have the bidirectional clipboard share activated and have also installed

sudo apt-get install virtualbox-guest-dkms

on the guest. But even after rebooting I can't copy/paste between the guest and host machine.

I am running Parcellite on the host,could that be a problem?

7

You should install virtualbox-guest-x11 package as dkms installs only the drivers. Then run the command VBoxClient --clipboard.

Sources How to fix virtualbox's copy and paste to host-machine?

| improve this answer | |
3

The method with 'VBoxClient --clipboard' did not work for me.

So, I downgraded VirtualBox from verison 6.1.4 to 6.1.2 and the problem disappeared.

| improve this answer | |
0

Using latest Virtual Box 6.1 on Windows10 host, using Ubuntu 18.04 guest

First I had installed by downloading How To Install VirtualBox Guest Additions on Ubuntu 18.04

sudo apt install build-essential dkms linux-headers-$(uname -r)

sudo sh ./VBoxLinuxAdditions.run --nox11

The install was successful, It should have worked but didn't

Next I did (as suggested above):
sudo apt-get install virtualbox-guest-dkms
VBoxClient --clipboard

sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

This also did not work, I have rebooted and all that, enabled bidirectional - clipboard, drag-n-drop, etc.
Not only cut-n-paste does not work, I cant even scroll my mouse pointer above the prompt - so essentially makes the VM useless.
You would expect something like this to work by default, but unfortunately not, even after all the hoops.

| improve this answer | |
  • If you use Ubuntu Sever you can not use clipboard, mouse integration. Only Shared Folders. – adasiko Dec 18 '19 at 12:10
  • @ adasiko - I was not aware of this limitation, documentation etc are not clear about this. – Sam-T Dec 18 '19 at 15:55
  • The menu has enable clip board, drag drop etc - none of them work. I thought setting X11 etc would make it work. But total waste of time. (same with VM Player also) – Sam-T Dec 18 '19 at 16:02
  • As I "answered" above, I think that Oracle has a bug in their latest 6.1 release. I also noticed that, after a completely-proper install of the necessary software on host and guest, the clipboard-sharing broke. – Mike Robinson Feb 26 at 23:23
0

I did not get any response here and could not figure it out - tried many options. (Same problem with VMPlayer also)
But the good news, at least from cut-n-paste perspective, use alternate client. You can use ssh to login into the machine using your favorite tool - putty or even cmd will work. This actually is a better solution - no need to muck with mouse capture and all that.

So just setup a ssh server
sudo apt update sudo apt install openssh-server sudo systemctl status ssh
Active: active (running)

Open firewall
sudo ufw allow ssh

Check IP address
ip a

SSH in with PUtty or cmd or ..
ssh <username>@<ip_address>

You are Done - will work like a charm

Note: This ssh works only from local host as the VM only has Pvt IP. If you can create public IP on VM (that is another arduous adventure - still working on it) - you will be able to remote ssh

| improve this answer | |
0

I just upgraded my VirtualBox to 6.1, and the Guest Additions on my Ubuntu guest to the corresponding version, and right now I think that this introduced a bug because my clipboard-sharing also stopped working ... as soon as I upgraded. (Yes, I installed the Additions both on the host and on my Ubuntu guest.)

Therefore, I'm pretty sure that this is Oracle's bug, and that we'll be seeing a hot-fix coming out from them in a few days.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.