1

I did search and do a script:

$cat ./xrandr 
cvt 3840 2160 59.91
xrandr --newmode "4K" 711.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
xrandr --addmode XWAYLAND1 4K
xrandr --output XWAYLAND1 --mode 4K`

But now even that in the settings-->devices-->screen resolution I did not have a 3840x2160 mode to choose in the list.

When I run my script:

$ bash -x ./xrandr 
+ cvt 3840 2160 59.91
# 3840x2160 59.90 Hz (CVT) hsync: 133.99 kHz; pclk: 711.75 MHz
Modeline "3840x2160_59.91"  711.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
+ xrandr --newmode 4K 711.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  18
  Current serial number in output stream:  18
+ xrandr --addmode XWAYLAND1 4K
+ xrandr --output XWAYLAND1 --mode 4K
xrandr: Configure crtc 0 failed

What is the solution for that? I have Ubuntu 17.10. I had this resolution earlier...it just disappear.

  • 1
    You cannot use xrandr to add resolutions under Wayland. What do you mean you had this resolution earlier? Where you logged in under Xorg instead? Were you on 17.04, and after upgrading to 17.10 you don't see the resolution under Wayland? – dobey Nov 21 '17 at 19:14
  • I did full install of ubuntu 17.10. Connected 4K monitor and It was all OK to the moment I change down resolution to 2560x1440 mode. – Mario_bash Nov 21 '17 at 19:20
  • I tried to change to Xorg but there is no even 2560x1440 resolution in this list. – Mario_bash Nov 21 '17 at 19:21
  • Do you want 2560x1440 or 3840x2160? Have you tried setting to 1920x1080 and then rebooting to see if you can get 3840x2160 working again? – dobey Nov 21 '17 at 19:52
  • I would like to change to 3840x2160. – Mario_bash Nov 21 '17 at 20:01
2

All the problem was due to "Display Port 1.2" in Monitor Settings. Changing back to "Display Port 1.1" resolved problem. The resolution is in the list in gnome display settings.

It was really hard to diagnose that.

| improve this answer | |
  • 1
    where ica n find this option in 18.04 – shrw Apr 13 '19 at 11:00
0

You can reconfigure xOrg. I did this by creating a file in my /usr/share/X11/xorg.conf.d Directory.

I made it using vim:

sudo vim /usr/share/X11/xorg.conf.d/5-monitor.conf

Here is an example of my file

Section "Monitor"
   Identifier "Monitor0"
   Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
   Modeline "3840x2160_30.0" 297.00 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync
   Modeline "4096x2160_24.0" 297.00 4096 5116 5204 5500 2160 2168 2178 2250 +hsync +vsync
EndSection
Section "Device"
   Identifier "Device0"
   Driver "intel"
EndSection
Section "Screen"
   Identifier "Screen0"
   Device "Device0"
   Monitor "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Depth 24
      Modes "3840x2160" "1920x1080"
   EndSubSection
EndSection

For directions on how to do this you can follow this tutorial: https://wiki.gentoo.org/wiki/Xorg/Multiple_monitors

| improve this answer | |
  • I use wayland not X11. – Mario_bash Nov 21 '17 at 20:27
  • ok sorry about that. I haven't used wayland yet. I cant really give you much advice on that. – Jermayne Williams Nov 22 '17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.