1

I am having troubles with the volume on my computer. The keyboard is working fine but when I turn the volume up and down, the indicator shows it, but the sound doesn't change. If I start the computer with a low volume it stays low no matter what I do. If I plug in headphones they are not recognized. If I restart with headphones though, it stays with headphones setting (so it stays with whatever setting I start, and I'm not able to change it after start).

I already tried purging and reinstalling pulseaudio and erasing the configuration folders (.pulse) doesn't do anything.

Thanks

  • System: Ubuntu 16.04.3 LTS 64-bit
  • Memory: 16GB
  • Processor: Intel® Core™ i7-7700HQ CPU @ 2.80GHz × 8
  • Graphics: GeForce GTX 1050/PCIe/SSE2
  • Disk: 1TB
3
  • Now, something funny happened while I was replying to this. I went to the volume icon and clicked on "Sounds Settings" and the computer completely froze. I forced restarted it and now the sound icon is gone. I can still hear the sound, but cannot change it.
    – MsKK
    Nov 21, 2017 at 15:17
  • Used a fix described here: forums.linuxmint.com/viewtopic.php?t=91453. The only change I made is that I added [Element Speaker], besides the Master.
    – vlsh
    Aug 24, 2019 at 20:11
  • Keys working (pops up), Volume working, but they aren't connected. May happen when pulse-audio is restarted. Try fiddling with "Sound Preferences" -> Hardware" -> "Profile". Set to "Off", and see if the volume slider in the applet is now connected to the keys. Then put it back where it was. The exact sequence is a little fuzzy, so fiddle until it works. Also, for fun, look at pulsemixer. It presents the same slider in a more groovy fashion. Jul 18, 2021 at 19:37

3 Answers 3

3

At the end, it was this issue here.

I solved it by this solution mentioned there:

I think I may have solved the issue. Upon examining /etc/modprobe.d/alsa-base.conf, I noticed that it no longer had the following line.

options snd-hda-intel model=auto

I re-added this line, saved, rebooted, and everything seems to be working now.

1
  • 3
    No need to reboot the entire system though, just run: pulseaudio -k && sudo alsa force-reload
    – Bolli
    Dec 2, 2019 at 12:22
1

I had a similar issue on Ubuntu 19.10. My audio controls did not work and the volume indicator wouldn't even show up at all. These issues occured after messing around with QJackCTL. I can confirm that adding the above line into the alsa-base.conf file does fix the problem.

UPDATE: Another source of this issue is if you have QJackCTL set to run on login. Disabling this through Cadence or by some other means may fix the problem.

0

Ubuntu 20.04. When activating pulseeffects, volume control becomes disabled. Only control at that point is by the manual controls in pulseefects app. When pressing volume control on keyboard, speaker icon on screen says pulseeffects(mic). Fix = settings/sound/output change from pulseeffects(mic) to pulseeffects(apps) or headphones - built-in audio. Keyboard volume control and speaker slider works again with effects still active.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.