I run Ubuntu 16.04 as a Windows 10 dual boot on a HP with its built-in keyboard.

Specifications in picture

Specifications in picture

I noticed an annoying keyboard behaviour under Ubuntu. When I press a key, it can happen that the system repeats the key infinitely, even after I released the key. I think this bug only appears, if I press a key for a longer time, but the bug can't be always reproduced by pressing a key over an extended period of time.

This can happen with any key, but mostly I notice it with arrow keys (Annoyingly, sometimes one doesn't see anything, except that the program seems to be unresponsive, because the arrow key command overrules any further input). I can terminate the key repeat by pressing Esc or another arrow key.

I don't know, how to evoke this behaviour on purpose. It is not a computer problem per se - I have never noticed that behaviour, when using the Windows partition. It is also not a problem with the latest update - the problem exists for quite a while, I just happen to ask now.

I also tried this keyboard test from the related question section. Keys were shown as expected and the sticky key problem didn't appear. Which doesn't say much, since it sometimes does not happen for days.

  • There are a couple of items that you can check. Please execute the command gsettings get org.gnome.desktop.a11y.keyboard stickykeys-enable - this should return 'false'. Also look at this answer, and if you have a USB keyboard around, verify the problem is with the OS rather than the current keyboard Commented Nov 21, 2017 at 14:27
  • Thanks, for your answer, Charles. I edited now that the keyboard is a built-in keyboard and doesn't appear in the Windows partition. The command you suggested returns as expected false.
    – Mr. T
    Commented Nov 21, 2017 at 14:45
  • I also checked that keyboard input is set to IBus as suggested by the other thread, you pointed out.
    – Mr. T
    Commented Nov 21, 2017 at 14:56
  • I think this problem has been reported twice over the last few days by other users but don't have links handy. I think it deserves closer scrutiny. Commented Jan 8, 2018 at 4:24
  • @WinEunuuchs2Unix Sorry, if I gave the impression that this might be an update problem. Edited question now, that this is going on for quite a while.
    – Mr. T
    Commented Jan 8, 2018 at 11:48

3 Answers 3



xset r rate 250 60
xkbset bouncekeys 50

Tweak the numbers.

Also try:

xset r off


  • Thank you for your input. Although turning off the autorepeat is probably an option, I don't really want to do this, because I actually use in my daily routine this functionality. And I don't see the point in changing the autorepeat parameters. It is a random behaviour, as if the key is stuck from time to time in the keyboard - only it isn't. I can stop the involuntary repeat by pressing any other key and it never happens on the Windows partition of this dual-boot installation.
    – Mr. T
    Commented Sep 14, 2018 at 9:11
  • The source code to xkbset is available, @Mr.T. It may be possible to run a program that detects when repeated keys are happening and momentarily disables the repeater (similar to calling xset r off followed by xset r on). Definitely a hack and not guaranteed to work. Commented Sep 14, 2018 at 15:39

I experienced this issue using X2Go over VPN connection to Ubuntu 18.04.5 LTS. Going to Settings->Universal Access and in the Typing section turning off Repeat Keys seemed to fix the problem for me.

  • I had forgotten about this problem. One of the updates must have eradicated this problem - I have not experienced it in the last year or two. Coming to think of it, probably the 18.04 update killed it in my case.
    – Mr. T
    Commented Nov 6, 2020 at 0:00

I have exactly the same problem, but it seems, that the unwanted repeating only appears, when pressing a key too short. Try to press some keys very carefully, then it should work. If you hack your keys quick enough it comes to this issue. I don't know why, but there seems to be a minimum time, a key must be pressed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .